PKGBUILDs/extra/ruby/0003-Use-only-unsigned-long-for-rb_serial_t.patch
2019-01-15 04:37:20 +00:00

37 lines
955 B
Diff

From 8da8ccfc11050c25aa262db3e84a36bc74899de9 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 14 Jan 2019 21:34:02 -0700
Subject: [PATCH 3/3] Use only unsigned long for rb_serial_t
---
internal.h | 10 ----------
1 file changed, 10 deletions(-)
diff --git a/internal.h b/internal.h
index 433ab6635d..a4f7e9bde3 100644
--- a/internal.h
+++ b/internal.h
@@ -941,19 +941,9 @@ struct rb_subclass_entry {
rb_subclass_entry_t *next;
};
-#if defined(HAVE_LONG_LONG)
-typedef unsigned LONG_LONG rb_serial_t;
-#define SERIALT2NUM ULL2NUM
-#define PRI_SERIALT_PREFIX PRI_LL_PREFIX
-#elif defined(HAVE_UINT64_T)
-typedef uint64_t rb_serial_t;
-#define SERIALT2NUM SIZET2NUM
-#define PRI_SERIALT_PREFIX PRI_64_PREFIX
-#else
typedef unsigned long rb_serial_t;
#define SERIALT2NUM ULONG2NUM
#define PRI_SERIALT_PREFIX PRI_LONG_PREFIX
-#endif
struct rb_classext_struct {
struct st_table *iv_index_tbl;
--
2.20.1