mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
40 lines
1.4 KiB
Diff
40 lines
1.4 KiB
Diff
diff --git a/elf/Makefile b/elf/Makefile
|
|
index 8234ba7..25ffc57 100644
|
|
--- a/elf/Makefile
|
|
+++ b/elf/Makefile
|
|
@@ -1203,3 +1203,14 @@ $(objpfx)tst-relsort1mod1.so: $(libm) $(objpfx)tst-relsort1mod2.so
|
|
$(objpfx)tst-relsort1mod2.so: $(libm)
|
|
$(objpfx)tst-relsort1.out: $(objpfx)tst-relsort1mod1.so \
|
|
$(objpfx)tst-relsort1mod2.so
|
|
+
|
|
+tests: $(objpfx)tst-unused-dep.out
|
|
+
|
|
+$(objpfx)tst-unused-dep.out: $(objpfx)testobj1.so
|
|
+ LD_TRACE_LOADED_OBJECTS=1 \
|
|
+ LD_DEBUG=unused \
|
|
+ LD_PRELOAD= \
|
|
+ $(elf-objpfx)${rtld-installed-name} \
|
|
+ --library-path $(rpath-link)$(patsubst %,:%,$(sysdep-library-path)) \
|
|
+ $< > $@
|
|
+ cmp $@ /dev/null > /dev/null
|
|
diff --git a/elf/rtld.c b/elf/rtld.c
|
|
index 2e4f97f..3e15447 100644
|
|
--- a/elf/rtld.c
|
|
+++ b/elf/rtld.c
|
|
@@ -1,5 +1,5 @@
|
|
/* Run time dynamic linker.
|
|
- Copyright (C) 1995-2010, 2011 Free Software Foundation, Inc.
|
|
+ Copyright (C) 1995-2012 Free Software Foundation, Inc.
|
|
This file is part of the GNU C Library.
|
|
|
|
The GNU C Library is free software; you can redistribute it and/or
|
|
@@ -1375,6 +1375,9 @@ of this helper program; chances are you did not intend to run this program.\n\
|
|
_dl_setup_hash (l);
|
|
l->l_relocated = 1;
|
|
|
|
+ /* The vDSO is always used. */
|
|
+ l->l_used = 1;
|
|
+
|
|
/* Initialize l_local_scope to contain just this map. This allows
|
|
the use of dl_lookup_symbol_x to resolve symbols within the vdso.
|
|
So we create a single entry list pointing to l_real as its only
|