mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
34 lines
1.3 KiB
Diff
34 lines
1.3 KiB
Diff
From 65261a822ebb355a22e1b876fff78d15fc1f2fe3 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Fri, 11 Dec 2015 20:06:54 -0700
|
|
Subject: [PATCH] char fix for ARM
|
|
|
|
---
|
|
rtengine/dcraw.cc | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/rtengine/dcraw.cc b/rtengine/dcraw.cc
|
|
index 8e0a36d..b47d856 100644
|
|
--- a/rtengine/dcraw.cc
|
|
+++ b/rtengine/dcraw.cc
|
|
@@ -1925,7 +1925,7 @@ void CLASS hasselblad_correct()
|
|
blur than this, but this does not need any buffer and makes nice-looking
|
|
radial gradients */
|
|
ushort *corners_weight = (ushort *)malloc(bw*bh*9*sizeof(*corners_weight));
|
|
- const char corners_mix[9][4][2] = { { {0,0}, {0,1}, {1,0}, {1,1} },
|
|
+ const signed char corners_mix[9][4][2] = { { {0,0}, {0,1}, {1,0}, {1,1} },
|
|
{ {0,1}, {1,1}, {-1,-1}, {-1,-1} },
|
|
{ {0,1}, {0,2}, {1,1}, {1,2} },
|
|
{ {1,0}, {1,1}, {-1,-1}, {-1,-1} },
|
|
@@ -2434,7 +2434,7 @@ void CLASS quicktake_100_load_raw()
|
|
|
|
void CLASS kodak_radc_load_raw()
|
|
{
|
|
- static const char src[] = {
|
|
+ static const signed char src[] = {
|
|
1,1, 2,3, 3,4, 4,2, 5,7, 6,5, 7,6, 7,8,
|
|
1,0, 2,1, 3,3, 4,4, 5,2, 6,7, 7,6, 8,5, 8,8,
|
|
2,1, 2,3, 3,0, 3,2, 3,4, 4,6, 5,5, 6,7, 6,8,
|
|
--
|
|
2.6.2
|
|
|