mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
32 lines
1.3 KiB
Diff
32 lines
1.3 KiB
Diff
From 5713cd629c97c7a12a600a1dd73ad81d87374eb1 Mon Sep 17 00:00:00 2001
|
|
From: Evangelos Foutras <evangelos@foutrelis.com>
|
|
Date: Sat, 12 May 2018 11:52:18 +0300
|
|
Subject: [PATCH] makechrootpkg: add /etc/shadow entry for builduser
|
|
|
|
Without it, sudo 1.8.23 will return an error:
|
|
|
|
sudo: PAM account management error: Authentication
|
|
service cannot retrieve authentication info
|
|
---
|
|
makechrootpkg.in | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
|
index 8e33499..57231d5 100644
|
|
--- a/makechrootpkg.in
|
|
+++ b/makechrootpkg.in
|
|
@@ -176,9 +176,10 @@ prepare_chroot() {
|
|
# We can't use useradd without chrooting, otherwise it invokes PAM modules
|
|
# which we might not be able to load (i.e. when building i686 packages on
|
|
# an x86_64 host).
|
|
- sed -e '/^builduser:/d' -i "$copydir"/etc/{passwd,group}
|
|
+ sed -e '/^builduser:/d' -i "$copydir"/etc/{passwd,shadow,group}
|
|
printf >>"$copydir/etc/group" 'builduser:x:%d:\n' "$builduser_gid"
|
|
printf >>"$copydir/etc/passwd" 'builduser:x:%d:%d:builduser:/build:/bin/bash\n' "$builduser_uid" "$builduser_gid"
|
|
+ printf >>"$copydir/etc/shadow" 'builduser:!!:%d::::::\n' "$(( $(date -u +%s) / 86400 ))"
|
|
|
|
$install -d "$copydir"/{build,build/.gnupg,startdir,{pkg,srcpkg,src,log}dest}
|
|
|
|
--
|
|
2.17.0
|
|
|