mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
34 lines
1.1 KiB
Diff
34 lines
1.1 KiB
Diff
From 15bac72bac03faeb3b725b1d208c62160f0c3ad7 Mon Sep 17 00:00:00 2001
|
|
From: Ulrich Drepper <drepper@redhat.com>
|
|
Date: Wed, 11 Aug 2010 07:44:03 -0700
|
|
Subject: [PATCH] Fix IPTOS_CLASS definition.
|
|
|
|
---
|
|
ChangeLog | 4 ++++
|
|
NEWS | 4 ++--
|
|
sysdeps/generic/netinet/ip.h | 5 ++---
|
|
3 files changed, 8 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/sysdeps/generic/netinet/ip.h b/sysdeps/generic/netinet/ip.h
|
|
index a837b98..4955fee 100644
|
|
--- a/sysdeps/generic/netinet/ip.h
|
|
+++ b/sysdeps/generic/netinet/ip.h
|
|
@@ -1,5 +1,4 @@
|
|
-/* Copyright (C) 1991,92,93,95,96,97,98,99,2000,2009 Free Software
|
|
- Foundation, Inc.
|
|
+/* Copyright (C) 1991-1993,1995-2000,2009,2010 Free Software Foundation, Inc.
|
|
This file is part of the GNU C Library.
|
|
|
|
The GNU C Library is free software; you can redistribute it and/or
|
|
@@ -194,7 +193,7 @@ struct ip_timestamp
|
|
*/
|
|
|
|
#define IPTOS_CLASS_MASK 0xe0
|
|
-#define IPTOS_CLASS(class) ((tos) & IPTOS_CLASS_MASK)
|
|
+#define IPTOS_CLASS(class) ((class) & IPTOS_CLASS_MASK)
|
|
#define IPTOS_CLASS_CS0 0x00
|
|
#define IPTOS_CLASS_CS1 0x20
|
|
#define IPTOS_CLASS_CS2 0x40
|
|
--
|
|
1.7.2
|
|
|