mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
23 lines
784 B
Diff
23 lines
784 B
Diff
diff -ruN net-tools-1.60.orig/lib/x25_sr.c net-tools-1.60/lib/x25_sr.c
|
|
--- net-tools-1.60.orig/lib/x25_sr.c 2000-05-20 15:38:10.000000000 +0200
|
|
+++ net-tools-1.60/lib/x25_sr.c 2003-10-18 20:33:31.927574928 +0200
|
|
@@ -22,6 +22,7 @@
|
|
#include <sys/socket.h>
|
|
#include <sys/ioctl.h>
|
|
#include <linux/x25.h>
|
|
+#include <linux/version.h>
|
|
#include <ctype.h>
|
|
#include <errno.h>
|
|
#include <netdb.h>
|
|
@@ -77,7 +78,11 @@
|
|
rt.sigdigits=sigdigits;
|
|
|
|
/* x25_route_struct.address isn't type struct sockaddr_x25, Why? */
|
|
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 0)
|
|
memcpy(&rt.address, &sx25.sx25_addr, sizeof(x25_address));
|
|
+#else
|
|
+ memcpy(&rt.address, &sx25.sx25_addr, sizeof(struct x25_address));
|
|
+#endif
|
|
|
|
while (*args) {
|
|
if (!strcmp(*args,"device") || !strcmp(*args,"dev")) {
|