mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
24 lines
1 KiB
Diff
24 lines
1 KiB
Diff
diff -Nur boost_1_41_0.orig/boost/iostreams/filter/zlib.hpp boost_1_41_0/boost/iostreams/filter/zlib.hpp
|
|
--- boost_1_41_0.orig/boost/iostreams/filter/zlib.hpp 2009-10-14 18:20:36.000000000 +0300
|
|
+++ boost_1_41_0/boost/iostreams/filter/zlib.hpp 2009-12-13 16:47:53.078056507 +0200
|
|
@@ -20,6 +20,7 @@
|
|
#include <memory> // allocator, bad_alloc.
|
|
#include <new>
|
|
#include <boost/config.hpp> // MSVC, STATIC_CONSTANT, DEDUCED_TYPENAME, DINKUM.
|
|
+#include <boost/cstdint.hpp> // uint*_t
|
|
#include <boost/detail/workaround.hpp>
|
|
#include <boost/iostreams/constants.hpp> // buffer size.
|
|
#include <boost/iostreams/detail/config/auto_link.hpp>
|
|
@@ -43,9 +44,9 @@
|
|
namespace zlib {
|
|
// Typedefs
|
|
|
|
-typedef unsigned int uint;
|
|
-typedef unsigned char byte;
|
|
-typedef unsigned long ulong;
|
|
+typedef uint32_t uint;
|
|
+typedef uint8_t byte;
|
|
+typedef uint32_t ulong;
|
|
|
|
// Prefix 'x' prevents symbols from being redefined when Z_PREFIX is defined
|
|
typedef void* (*xalloc_func)(void*, zlib::uint, zlib::uint);
|