mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
83 lines
2.9 KiB
Diff
83 lines
2.9 KiB
Diff
diff --git a/contrib/android/perms.c b/contrib/android/perms.c
|
|
index d83ad35a..dca5b620 100644
|
|
--- a/contrib/android/perms.c
|
|
+++ b/contrib/android/perms.c
|
|
@@ -5,6 +5,7 @@
|
|
#include "support/nls-enable.h"
|
|
#include <time.h>
|
|
#include <sys/stat.h>
|
|
+#include "private/android_filesystem_capability.h"
|
|
|
|
#ifndef XATTR_SELINUX_SUFFIX
|
|
# define XATTR_SELINUX_SUFFIX "selinux"
|
|
diff --git a/lib/ext2fs/bitops.h b/lib/ext2fs/bitops.h
|
|
index 505b3c9c..7be5105f 100644
|
|
--- a/lib/ext2fs/bitops.h
|
|
+++ b/lib/ext2fs/bitops.h
|
|
@@ -233,11 +233,11 @@ extern errcode_t ext2fs_find_first_set_generic_bmap(ext2fs_generic_bitmap bitmap
|
|
#if (__STDC_VERSION__ >= 199901L)
|
|
#define _INLINE_ extern inline
|
|
#else
|
|
-#define _INLINE_ inline
|
|
+#define _INLINE_ static inline
|
|
#endif
|
|
#else /* !INCLUDE_INLINE FUNCS */
|
|
#if (__STDC_VERSION__ >= 199901L)
|
|
-#define _INLINE_ inline
|
|
+#define _INLINE_ static inline
|
|
#else /* not C99 */
|
|
#ifdef __GNUC__
|
|
#define _INLINE_ extern __inline__
|
|
diff --git a/lib/ext2fs/ext2fs.h b/lib/ext2fs/ext2fs.h
|
|
index 470e7d7a..95a41e0d 100644
|
|
--- a/lib/ext2fs/ext2fs.h
|
|
+++ b/lib/ext2fs/ext2fs.h
|
|
@@ -1743,7 +1743,7 @@ extern const struct ext2_inode *ext2fs_const_inode(const struct ext2_inode_large
|
|
#define _INLINE_ extern
|
|
#else
|
|
#if (__STDC_VERSION__ >= 199901L)
|
|
-#define _INLINE_ inline
|
|
+#define _INLINE_ static inline
|
|
#else
|
|
#ifdef __GNUC__
|
|
#define _INLINE_ extern __inline__
|
|
diff --git a/misc/create_inode.c b/misc/create_inode.c
|
|
index 1373b46b..e6f34bd9 100644
|
|
--- a/misc/create_inode.c
|
|
+++ b/misc/create_inode.c
|
|
@@ -403,7 +403,7 @@ static ssize_t my_pread(int fd, void *buf, size_t count, off_t offset)
|
|
}
|
|
#endif /* !defined HAVE_PREAD64 && !defined HAVE_PREAD */
|
|
|
|
-static errcode_t copy_file_range(ext2_filsys fs, int fd, ext2_file_t e2_file,
|
|
+static errcode_t e2_copy_file_range(ext2_filsys fs, int fd, ext2_file_t e2_file,
|
|
off_t start, off_t end, char *buf,
|
|
char *zerobuf)
|
|
{
|
|
@@ -477,7 +477,7 @@ static errcode_t try_lseek_copy(ext2_filsys fs, int fd, struct stat *statbuf,
|
|
|
|
data_blk = data & ~(fs->blocksize - 1);
|
|
hole_blk = (hole + (fs->blocksize - 1)) & ~(fs->blocksize - 1);
|
|
- err = copy_file_range(fs, fd, e2_file, data_blk, hole_blk, buf,
|
|
+ err = e2_copy_file_range(fs, fd, e2_file, data_blk, hole_blk, buf,
|
|
zerobuf);
|
|
if (err)
|
|
return err;
|
|
@@ -527,7 +527,7 @@ static errcode_t try_fiemap_copy(ext2_filsys fs, int fd, ext2_file_t e2_file,
|
|
}
|
|
for (i = 0, ext = ext_buf; i < fiemap_buf->fm_mapped_extents;
|
|
i++, ext++) {
|
|
- err = copy_file_range(fs, fd, e2_file, ext->fe_logical,
|
|
+ err = e2_copy_file_range(fs, fd, e2_file, ext->fe_logical,
|
|
ext->fe_logical + ext->fe_length,
|
|
buf, zerobuf);
|
|
if (err)
|
|
@@ -580,7 +580,7 @@ static errcode_t copy_file(ext2_filsys fs, int fd, struct stat *statbuf,
|
|
goto out;
|
|
#endif
|
|
|
|
- err = copy_file_range(fs, fd, e2_file, 0, statbuf->st_size, buf,
|
|
+ err = e2_copy_file_range(fs, fd, e2_file, 0, statbuf->st_size, buf,
|
|
zerobuf);
|
|
out:
|
|
ext2fs_free_mem(&zerobuf);
|