PKGBUILDs/extra/chromium/0003-Run-blink-bindings-generation-single-threaded.patch
2021-04-15 02:51:28 +00:00

26 lines
892 B
Diff

From c2c53f8f86eaf1fa5803b0c67e6fab3cc7722775 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 2 Feb 2021 13:58:59 -0700
Subject: [PATCH 3/4] Run blink bindings generation single threaded
When not single threaded this process will eat all the RAM.
---
third_party/blink/renderer/bindings/BUILD.gn | 1 +
1 file changed, 1 insertion(+)
diff --git a/third_party/blink/renderer/bindings/BUILD.gn b/third_party/blink/renderer/bindings/BUILD.gn
index 61c9e7f59da7..a33c9e4144df 100644
--- a/third_party/blink/renderer/bindings/BUILD.gn
+++ b/third_party/blink/renderer/bindings/BUILD.gn
@@ -178,6 +178,7 @@ template("generate_bindings") {
outputs = invoker.outputs
args = [
+ "--single_process",
"--web_idl_database",
rebase_path(web_idl_database, root_build_dir),
"--root_src_dir",
--
2.30.1