mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
22 lines
711 B
Diff
22 lines
711 B
Diff
--- utils/statd/start-statd 2007-05-11 04:40:57.000000000 +0100
|
|
+++ utils/statd/start-statd.new 2007-09-21 17:11:34.000000000 +0100
|
|
@@ -1,9 +1,16 @@
|
|
-#!/bin/bash -p
|
|
+#!/bin/sh
|
|
+
|
|
+# Original script provided by the NFS project
|
|
+# Modified for Arch Linux by Tom Killian
|
|
+
|
|
# nfsmount calls this script when mounting a filesystem with locking
|
|
# enabled, but when statd does not seem to be running (based on
|
|
# /var/run/rpc.statd.pid).
|
|
# It should run statd with whatever flags are apropriate for this
|
|
# site.
|
|
-PATH=/sbin:/usr/sbin
|
|
-exec rpc.statd --no-notify
|
|
+
|
|
+# source application-specific settings
|
|
+[ -f /etc/conf.d/nfs-common.conf ] && . /etc/conf.d/nfs-common.conf
|
|
+
|
|
+exec /usr/sbin/rpc.statd $STATD_OPTS
|
|
|