mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
84 lines
4 KiB
Diff
84 lines
4 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
|
Date: Fri, 12 Mar 2021 17:31:56 +0100
|
|
Subject: [PATCH] compiler: Change LLVM targets
|
|
|
|
- Change x86_64-unknown-linux-gnu to use x86_64-pc-linux-gnu
|
|
- Change i686-unknown-linux-gnu to use i686-pc-linux-gnu
|
|
|
|
Reintroduce the aliasing that was removed in 1.52.0 and alias the -pc-
|
|
triples to the -unknown- triples. This avoids defining proper -pc-
|
|
targets, as things break when this is done:
|
|
|
|
- The crate ecosystem expects the -unknown- targets. Making -pc-
|
|
rustc's host triple (and thus default target) would break various
|
|
crates.
|
|
- Firefox's build breaks when the host triple (from
|
|
`rustc --version --verbose`) is different from the target triple
|
|
(from `rustc --print target-list`) that best matches autoconf.
|
|
---
|
|
compiler/rustc_session/src/config.rs | 2 +-
|
|
compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs | 2 +-
|
|
compiler/rustc_target/src/spec/mod.rs | 9 +++++++++
|
|
.../rustc_target/src/spec/x86_64_unknown_linux_gnu.rs | 2 +-
|
|
4 files changed, 12 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
|
|
index ad2b36691b5..0c57c774f24 100644
|
|
--- a/compiler/rustc_session/src/config.rs
|
|
+++ b/compiler/rustc_session/src/config.rs
|
|
@@ -1507,7 +1507,7 @@ fn parse_target_triple(matches: &getopts::Matches, error_format: ErrorOutputType
|
|
early_error(error_format, &format!("target file {:?} does not exist", path))
|
|
})
|
|
}
|
|
- Some(target) => TargetTriple::TargetTriple(target),
|
|
+ Some(target) => TargetTriple::from_alias(target),
|
|
_ => TargetTriple::from_triple(host_triple()),
|
|
}
|
|
}
|
|
diff --git a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
|
index 165505ee731..00a7f5c2f8c 100644
|
|
--- a/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
|
+++ b/compiler/rustc_target/src/spec/i686_unknown_linux_gnu.rs
|
|
@@ -9,7 +9,7 @@ pub fn target() -> Target {
|
|
base.stack_probes = StackProbeType::Call;
|
|
|
|
Target {
|
|
- llvm_target: "i686-unknown-linux-gnu".to_string(),
|
|
+ llvm_target: "i686-pc-linux-gnu".to_string(),
|
|
pointer_width: 32,
|
|
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
|
|
f64:32:64-f80:32-n8:16:32-S128"
|
|
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
|
index 2af46693449..a2c6cf49f9c 100644
|
|
--- a/compiler/rustc_target/src/spec/mod.rs
|
|
+++ b/compiler/rustc_target/src/spec/mod.rs
|
|
@@ -2137,6 +2137,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
|
Ok(TargetTriple::TargetPath(canonicalized_path))
|
|
}
|
|
|
|
+ /// Creates a target triple from its alias
|
|
+ pub fn from_alias(triple: String) -> Self {
|
|
+ match triple.as_str() {
|
|
+ "x86_64-pc-linux-gnu" => TargetTriple::from_triple("x86_64-unknown-linux-gnu"),
|
|
+ "i686-pc-linux-gnu" => TargetTriple::from_triple("i686-unknown-linux-gnu"),
|
|
+ _ => TargetTriple::TargetTriple(triple),
|
|
+ }
|
|
+ }
|
|
+
|
|
/// Returns a string triple for this target.
|
|
///
|
|
/// If this target is a path, the file name (without extension) is returned.
|
|
diff --git a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
|
index 085079e06e5..2dfa6a040b1 100644
|
|
--- a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
|
+++ b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
|
@@ -11,7 +11,7 @@ pub fn target() -> Target {
|
|
SanitizerSet::ADDRESS | SanitizerSet::LEAK | SanitizerSet::MEMORY | SanitizerSet::THREAD;
|
|
|
|
Target {
|
|
- llvm_target: "x86_64-unknown-linux-gnu".to_string(),
|
|
+ llvm_target: "x86_64-pc-linux-gnu".to_string(),
|
|
pointer_width: 64,
|
|
data_layout: "e-m:e-p270:32:32-p271:32:32-p272:64:64-i64:64-f80:128-n8:16:32:64-S128"
|
|
.to_string(),
|