PKGBUILDs/alarm/devtools-alarm/0006-archbuild-no-setarch.patch
Evan Teitelman f38e52e29e alarm/devtools-alarm: Remove setarch from a call to mkarchroot.
setarch does not support ARM architectures. Without this patch,
archbuild fails with this error:

    setarch: armv6h: Unrecognized architecture

This patch is similar in intent to the first hunk of
0004-arch-nspawn-arm-fix.patch.
2014-02-16 08:02:19 -05:00

12 lines
400 B
Diff

--- a/archbuild.in 2014-02-16 07:57:21.777365491 -0500
+++ b/archbuild.in 2014-02-16 07:57:54.280700229 -0500
@@ -62,7 +62,7 @@
rm -rf --one-file-system "${chroots}/${repo}-${arch}"
mkdir -p "${chroots}/${repo}-${arch}"
- setarch "${arch}" mkarchroot \
+ mkarchroot \
-C "@pkgdatadir@/pacman-${repo}.conf" \
-M "@pkgdatadir@/makepkg-${arch}.conf" \
"${chroots}/${repo}-${arch}/root" \