mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
35 lines
849 B
Diff
35 lines
849 B
Diff
--- a/version/version.go 2018-06-26 09:57:33.703932696 +0200
|
|
+++ b/version/version.go 2018-06-26 09:59:05.986536238 +0200
|
|
@@ -1,7 +1,6 @@
|
|
package version
|
|
|
|
import (
|
|
- "fmt"
|
|
"strings"
|
|
)
|
|
|
|
@@ -27,24 +26,6 @@ var (
|
|
// for displaying to humans.
|
|
func GetHumanVersion() string {
|
|
version := Version
|
|
- if GitDescribe != "" {
|
|
- version = GitDescribe
|
|
- }
|
|
-
|
|
- release := VersionPrerelease
|
|
- if GitDescribe == "" && release == "" {
|
|
- release = "dev"
|
|
- }
|
|
-
|
|
- if release != "" {
|
|
- if !strings.HasSuffix(version, "-"+release) {
|
|
- // if we tagged a prerelease version then the release is in the version already
|
|
- version += fmt.Sprintf("-%s", release)
|
|
- }
|
|
- if GitCommit != "" {
|
|
- version += fmt.Sprintf(" (%s)", GitCommit)
|
|
- }
|
|
- }
|
|
|
|
// Strip off any single quotes added by the git information.
|
|
return strings.Replace(version, "'", "", -1)
|