PKGBUILDs/community/mongodb/disable-sslv3.patch
2016-03-06 16:30:48 +00:00

27 lines
1.1 KiB
Diff

diff -u -r mongodb-src-r3.2.3/src/third_party/asio-asio-1-11-0/asio/include/asio/ssl/impl/context.ipp mongodb-src-r3.2.3-nossl3/src/third_party/asio-asio-1-11-0/asio/include/asio/ssl/impl/context.ipp
--- mongodb-src-r3.2.3/src/third_party/asio-asio-1-11-0/asio/include/asio/ssl/impl/context.ipp 2016-02-17 19:57:55.000000000 +0100
+++ mongodb-src-r3.2.3-nossl3/src/third_party/asio-asio-1-11-0/asio/include/asio/ssl/impl/context.ipp 2016-03-03 18:24:21.321007930 +0100
@@ -84,6 +84,14 @@
handle_ = ::SSL_CTX_new(::SSLv2_server_method());
break;
#endif // defined(OPENSSL_NO_SSL2)
+#if defined(OPENSSL_NO_SSL3)
+ case context::sslv3:
+ case context::sslv3_client:
+ case context::sslv3_server:
+ asio::detail::throw_error(
+ asio::error::invalid_argument, "context");
+ break;
+#else // defined(OPENSSL_NO_SSL3)
case context::sslv3:
handle_ = ::SSL_CTX_new(::SSLv3_method());
break;
@@ -93,6 +101,7 @@
case context::sslv3_server:
handle_ = ::SSL_CTX_new(::SSLv3_server_method());
break;
+#endif // defined(OPENSSL_NO_SSL3)
case context::tlsv1:
handle_ = ::SSL_CTX_new(::TLSv1_method());
break;