PKGBUILDs/alarm/uboot-usbarmory/0001-arch-linux-arm-modifications.patch
2015-06-27 22:27:35 +00:00

39 lines
1 KiB
Diff

From 6b6652055bab1024b85422526c7624b303c7e5a5 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 27 Jun 2015 12:37:40 -0600
Subject: [PATCH] arch linux arm modifications
---
include/config_distro_defaults.h | 3 +++
include/configs/usbarmory.h | 2 ++
2 files changed, 5 insertions(+)
diff --git a/include/config_distro_defaults.h b/include/config_distro_defaults.h
index 8237239..2477edf 100644
--- a/include/config_distro_defaults.h
+++ b/include/config_distro_defaults.h
@@ -59,4 +59,7 @@
#define CONFIG_SUPPORT_RAW_INITRD
#define CONFIG_SYS_HUSH_PARSER
+#define CONFIG_CMD_PART
+#define CONFIG_PARTITION_UUIDS
+
#endif /* _CONFIG_CMD_DISTRO_DEFAULTS_H */
diff --git a/include/configs/usbarmory.h b/include/configs/usbarmory.h
index f29ab2d..9a947d2 100644
--- a/include/configs/usbarmory.h
+++ b/include/configs/usbarmory.h
@@ -24,6 +24,8 @@
#include <config_distro_defaults.h>
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
+
/* U-Boot commands */
#define CONFIG_CMD_MEMTEST
#undef CONFIG_CMD_IMLS
--
2.4.4