PKGBUILDs/extra/meson/0001-tests-skip-objc-nsstring-test-if-gnustep-is-not-inst.patch
2018-01-28 14:35:46 +00:00

30 lines
1.1 KiB
Diff

From 89d4decc9cdda01590c2a734c0f58924bcf30777 Mon Sep 17 00:00:00 2001
Message-Id: <89d4decc9cdda01590c2a734c0f58924bcf30777.1517146929.git.jan.steffens@gmail.com>
From: Dylan Baker <dylan@pnwbakers.com>
Date: Tue, 19 Dec 2017 20:05:24 -0800
Subject: [PATCH 1/2] tests: skip objc nsstring test if gnustep is not
installed
---
test cases/objc/2 nsstring/meson.build | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/test cases/objc/2 nsstring/meson.build b/test cases/objc/2 nsstring/meson.build
index a877d746..7f2483f4 100644
--- a/test cases/objc/2 nsstring/meson.build
+++ b/test cases/objc/2 nsstring/meson.build
@@ -5,7 +5,10 @@ if host_machine.system() == 'darwin'
elif host_machine.system() == 'cygwin'
error('MESON_SKIP_TEST GNUstep is not packaged for Cygwin.')
else
- dep = dependency('gnustep')
+ dep = dependency('gnustep', required : false)
+ if not dep.found()
+ error('MESON_SKIP_TEST: GNUstep is not installed')
+ endif
if host_machine.system() == 'linux' and meson.get_compiler('objc').get_id() == 'clang'
error('MESON_SKIP_TEST: GNUstep is broken on Linux with Clang')
endif
--
2.16.1