mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
52 lines
1.8 KiB
Diff
52 lines
1.8 KiB
Diff
From 5bbe0af1be3af18793e3062bfd4f26bd194af88a Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Tue, 13 Oct 2015 20:45:53 -0600
|
|
Subject: [PATCH] arm fixes
|
|
|
|
---
|
|
configure | 5 ++++-
|
|
deps/v8/build/toolchain.gypi | 4 ++--
|
|
2 files changed, 6 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/configure b/configure
|
|
index 00f20f7..464c7c8 100755
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -636,8 +636,11 @@ def configure_arm(o):
|
|
if is_arch_armv7():
|
|
arm_fpu = 'vfpv3'
|
|
o['variables']['arm_version'] = '7'
|
|
+ elif is_arch_armv6():
|
|
+ o['variables']['arm_version'] = '6'
|
|
else:
|
|
- o['variables']['arm_version'] = '6' if is_arch_armv6() else 'default'
|
|
+ o['variables']['arm_fpu'] = ''
|
|
+ o['variables']['arm_version'] = '5'
|
|
|
|
o['variables']['arm_thumb'] = 0 # -marm
|
|
o['variables']['arm_float_abi'] = arm_float_abi
|
|
diff --git a/deps/v8/build/toolchain.gypi b/deps/v8/build/toolchain.gypi
|
|
index a8a3b56..a03cd13 100644
|
|
--- a/deps/v8/build/toolchain.gypi
|
|
+++ b/deps/v8/build/toolchain.gypi
|
|
@@ -203,7 +203,7 @@
|
|
}],
|
|
[ 'arm_version==7 or arm_version=="default"', {
|
|
'conditions': [
|
|
- [ 'arm_fpu!="default"', {
|
|
+ [ 'arm_fpu!="default" and arm_fpu!=""', {
|
|
'cflags': ['-mfpu=<(arm_fpu)',],
|
|
}],
|
|
],
|
|
@@ -246,7 +246,7 @@
|
|
}],
|
|
[ 'arm_version==7 or arm_version=="default"', {
|
|
'conditions': [
|
|
- [ 'arm_fpu!="default"', {
|
|
+ [ 'arm_fpu!="default" and arm_fpu!=""', {
|
|
'cflags': ['-mfpu=<(arm_fpu)',],
|
|
}],
|
|
],
|
|
--
|
|
2.7.0
|
|
|