mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
52 lines
1.7 KiB
Diff
52 lines
1.7 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Lionel Landwerlin <lionel.g.landwerlin@intel.com>
|
|
Date: Sun, 12 Jun 2022 23:59:05 +0300
|
|
Subject: [PATCH] anv: force MEDIA_INTERFACE_DESCRIPTOR_LOAD reemit after
|
|
3D->GPGPU switch
|
|
|
|
Seems to fix a hang in the following titles :
|
|
- Age of Empire 4
|
|
- Monster Hunter Rise
|
|
|
|
where the HW is hung on a PIPE_CONTROL after a GPGPU_WALKER but no
|
|
MEDIA_INTERFACE_DESCRIPTOR_LOAD was emitted since the switch from 3D
|
|
to GPGPU.
|
|
|
|
This would happen in the following case :
|
|
|
|
vkCmdBindPipeline(COMPUTE, cs_pipeline);
|
|
vkCmdDispatch(...);
|
|
vkCmdBindPipeline(GRAPHICS, gfx_pipeline);
|
|
vkCmdDraw(...);
|
|
vkCmdDispatch(...);
|
|
|
|
Signed-off-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com>
|
|
---
|
|
src/intel/vulkan/genX_cmd_buffer.c | 14 ++++++++++++++
|
|
1 file changed, 14 insertions(+)
|
|
|
|
diff --git a/src/intel/vulkan/genX_cmd_buffer.c b/src/intel/vulkan/genX_cmd_buffer.c
|
|
index 17629fb7ac87..1651c29d9ebd 100644
|
|
--- a/src/intel/vulkan/genX_cmd_buffer.c
|
|
+++ b/src/intel/vulkan/genX_cmd_buffer.c
|
|
@@ -6003,6 +6003,20 @@ genX(flush_pipeline_select)(struct anv_cmd_buffer *cmd_buffer,
|
|
}
|
|
#endif
|
|
|
|
+#if GFX_VERx10 == 120
|
|
+ /* Undocumented workaround to force the re-emission of
|
|
+ * MEDIA_INTERFACE_DESCRIPTOR_LOAD when switching from 3D to Compute
|
|
+ * pipeline without rebinding a pipeline :
|
|
+ * vkCmdBindPipeline(COMPUTE, cs_pipeline);
|
|
+ * vkCmdDispatch(...);
|
|
+ * vkCmdBindPipeline(GRAPHICS, gfx_pipeline);
|
|
+ * vkCmdDraw(...);
|
|
+ * vkCmdDispatch(...);
|
|
+ */
|
|
+ if (pipeline == _3D)
|
|
+ cmd_buffer->state.compute.pipeline_dirty = true;
|
|
+#endif
|
|
+
|
|
/* From "BXML » GT » MI » vol1a GPU Overview » [Instruction]
|
|
* PIPELINE_SELECT [DevBWR+]":
|
|
*
|