mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
67 lines
2.2 KiB
Diff
67 lines
2.2 KiB
Diff
diff -urN gtkmathview-0.8.0-orig/mathmlps/main.cc gtkmathview-0.8.0/mathmlps/main.cc
|
|
--- gtkmathview-0.8.0-orig/mathmlps/main.cc 2008-04-03 22:43:06.000000000 +0400
|
|
+++ gtkmathview-0.8.0/mathmlps/main.cc 2008-04-03 23:53:16.000000000 +0400
|
|
@@ -20,6 +20,7 @@
|
|
|
|
#include <cassert>
|
|
#include <fstream>
|
|
+#include <cstring>
|
|
|
|
#include <popt.h>
|
|
|
|
diff -urN gtkmathview-0.8.0-orig/mathmlsvg/main.cc gtkmathview-0.8.0/mathmlsvg/main.cc
|
|
--- gtkmathview-0.8.0-orig/mathmlsvg/main.cc 2008-04-03 22:43:05.000000000 +0400
|
|
+++ gtkmathview-0.8.0/mathmlsvg/main.cc 2008-04-03 23:43:31.000000000 +0400
|
|
@@ -20,6 +20,7 @@
|
|
|
|
#include <cassert>
|
|
#include <fstream>
|
|
+#include <cstring>
|
|
|
|
#include <popt.h>
|
|
|
|
diff -urN gtkmathview-0.8.0-orig/mathmlsvg/SMS.cc gtkmathview-0.8.0/mathmlsvg/SMS.cc
|
|
--- gtkmathview-0.8.0-orig/mathmlsvg/SMS.cc 2008-04-03 22:43:05.000000000 +0400
|
|
+++ gtkmathview-0.8.0/mathmlsvg/SMS.cc 2008-04-03 23:25:12.000000000 +0400
|
|
@@ -19,6 +19,7 @@
|
|
#include <config.h>
|
|
|
|
#include <sstream>
|
|
+#include <cstring>
|
|
#include "defs.h"
|
|
#include "AbstractLogger.hh"
|
|
#include "ValueConversion.hh"
|
|
diff -urN gtkmathview-0.8.0-orig/src/engine/mathml/mathVariantAux.cc gtkmathview-0.8.0/src/engine/mathml/mathVariantAux.cc
|
|
--- gtkmathview-0.8.0-orig/src/engine/mathml/mathVariantAux.cc 2008-04-03 22:43:05.000000000 +0400
|
|
+++ gtkmathview-0.8.0/src/engine/mathml/mathVariantAux.cc 2008-04-03 23:10:05.000000000 +0400
|
|
@@ -20,6 +20,8 @@
|
|
|
|
#include <cassert>
|
|
|
|
+#include <cstring>
|
|
+
|
|
#include "mathVariantAux.hh"
|
|
|
|
static MathVariantAttributes vattr[] = {
|
|
diff -urN gtkmathview-0.8.0-orig/src/backend/ps/T1_FontDataBase.cc gtkmathview-0.8.0/src/backend/ps/T1_FontDataBase.cc
|
|
--- gtkmathview-0.8.0-orig/src/backend/ps/T1_FontDataBase.cc 2007-08-17 12:02:40.000000000 +0200
|
|
+++ gtkmathview-0.8.0/src/backend/ps/T1_FontDataBase.cc 2008-06-07 12:26:01.000000000 +0200
|
|
@@ -23,6 +23,7 @@
|
|
#include <stdlib.h>
|
|
#include <iostream>
|
|
#include <list>
|
|
+#include <cstring>
|
|
|
|
#include "String.hh"
|
|
#include "T1_FontDataBase.hh"
|
|
--- a/src/common/AbstractLogger.cc 2009-06-12 16:29:57.000000000 -0700
|
|
+++ b/src/common/AbstractLogger.cc 2009-06-12 16:29:57.000000000 -0700
|
|
@@ -18,6 +18,8 @@
|
|
|
|
#include <config.h>
|
|
|
|
+#include <cstdio>
|
|
+
|
|
#include <stdarg.h>
|
|
|
|
#include "AbstractLogger.hh"
|