PKGBUILDs/alarm/uboot-odroid/0002-odroid-x-support.patch
2015-11-21 19:51:37 +00:00

40 lines
1.1 KiB
Diff

From 0eaca48880b25df1a04dff34e7d5740e1df188f9 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 6 Feb 2015 05:40:56 -0700
Subject: [PATCH 2/2] odroid-x support
---
board/samsung/odroid/odroid.c | 2 +-
include/configs/odroid.h | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/board/samsung/odroid/odroid.c b/board/samsung/odroid/odroid.c
index 32155f1..f6fa7b7 100644
--- a/board/samsung/odroid/odroid.c
+++ b/board/samsung/odroid/odroid.c
@@ -64,7 +64,7 @@ void set_board_type(void)
const char *get_board_type(void)
{
- const char *board_type[] = {"u3", "x2"};
+ const char *board_type[] = {"u3", "x"};
return board_type[gd->board_type];
}
diff --git a/include/configs/odroid.h b/include/configs/odroid.h
index 8ae43e8..9ed9e5e 100644
--- a/include/configs/odroid.h
+++ b/include/configs/odroid.h
@@ -23,7 +23,7 @@
#define CONFIG_MACH_TYPE 4289
-#define CONFIG_NR_DRAM_BANKS 8
+#define CONFIG_NR_DRAM_BANKS 4
#define CONFIG_SYS_SDRAM_BASE 0x40000000
#define SDRAM_BANK_SIZE (256 << 20) /* 256 MB */
#define PHYS_SDRAM_1 CONFIG_SYS_SDRAM_BASE
--
2.6.2