mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
24 lines
841 B
Diff
24 lines
841 B
Diff
diff -Nur webrtc-audio-processing-0.1/src/typedefs.h webrtc-audio-processing-0.1.new/src/typedefs.h
|
|
--- webrtc-audio-processing-0.1/src/typedefs.h 2011-10-21 00:29:33.000000000 -0400
|
|
+++ webrtc-audio-processing-0.1.new/src/typedefs.h 2014-01-28 18:42:57.816865572 -0500
|
|
@@ -77,7 +77,19 @@
|
|
#define WEBRTC_ARCH_32_BITS
|
|
#define WEBRTC_ARCH_LITTLE_ENDIAN
|
|
#else
|
|
-#error Please add support for your architecture in typedefs.h
|
|
+/* instead of failing, use typical unix defines... */
|
|
+#if __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
|
|
+#define WEBRTC_ARCH_LITTLE_ENDIAN
|
|
+#elif __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
|
|
+#define WEBRTC_ARCH_BIG_ENDIAN
|
|
+#else
|
|
+#error __BYTE_ORDER__ isn't defined!
|
|
+#endif
|
|
+#if defined(__LP64__)
|
|
+#define WEBRTC_ARCH_64_BITS
|
|
+#else
|
|
+#define WEBRTC_ARCH_32_BITS
|
|
+#endif
|
|
#endif
|
|
|
|
#if defined(__SSE2__) || defined(_MSC_VER)
|