mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
31 lines
1.4 KiB
Diff
31 lines
1.4 KiB
Diff
From d5a248dbe933c5cbe3ba3d0c5eb8a035018ba6af Mon Sep 17 00:00:00 2001
|
|
From: Dan Williams <dcbw@redhat.com>
|
|
Date: Thu, 30 Oct 2014 14:23:00 -0500
|
|
Subject: [PATCH] sd-dhcp-client: clean up raw socket sd_event_source when
|
|
creating new UDP socket
|
|
|
|
The raw socket sd_event_source used for DHCP server solicitations
|
|
was simply dropped on the floor when creating the new UDP socket
|
|
after a lease has been acquired. Clean it up properly so we're
|
|
not still listening and responding to events on it.
|
|
---
|
|
src/libsystemd-network/sd-dhcp-client.c | 3 +++
|
|
1 file changed, 3 insertions(+)
|
|
|
|
diff --git a/src/libsystemd-network/sd-dhcp-client.c b/src/libsystemd-network/sd-dhcp-client.c
|
|
index 0eba4c3..1f7f238 100644
|
|
--- a/src/libsystemd-network/sd-dhcp-client.c
|
|
+++ b/src/libsystemd-network/sd-dhcp-client.c
|
|
@@ -1269,6 +1269,9 @@ static int client_handle_message(sd_dhcp_client *client, DHCPMessage *message,
|
|
if (r >= 0) {
|
|
client->timeout_resend =
|
|
sd_event_source_unref(client->timeout_resend);
|
|
+ client->receive_message =
|
|
+ sd_event_source_unref(client->receive_message);
|
|
+ client->fd = asynchronous_close(client->fd);
|
|
|
|
if (IN_SET(client->state, DHCP_STATE_REQUESTING,
|
|
DHCP_STATE_REBOOTING))
|
|
--
|
|
2.1.3
|
|
|