PKGBUILDs/core/shadow/xstrdup.patch
2009-09-26 09:35:50 -05:00

10 lines
291 B
Diff

--- shadow-4.1.2.1/libmisc/xmalloc.c 2008-08-30 21:55:44.000000000 -0500
+++ shadow-4.1.2.1/libmisc/xmalloc.c.new 2008-08-30 21:55:36.000000000 -0500
@@ -61,5 +61,6 @@
char *xstrdup (const char *str)
{
+ if(str == NULL) return NULL;
return strcpy (xmalloc (strlen (str) + 1), str);
}