mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
140 lines
4 KiB
Diff
140 lines
4 KiB
Diff
diff -Naur src/Makefile src-p/Makefile
|
|
--- src/Makefile 2007-08-20 16:47:41.000000000 +0200
|
|
+++ src-p/Makefile 2007-10-02 04:07:44.000000000 +0200
|
|
@@ -34,17 +34,17 @@
|
|
|
|
# Everything gets put in subdirectories of. . .
|
|
|
|
-TOPDIR= /usr/local
|
|
+TOPDIR= $(DESTDIR)/usr
|
|
|
|
# "Compiled" time zone information is placed in the "TZDIR" directory
|
|
# (and subdirectories).
|
|
# Use an absolute path name for TZDIR unless you're just testing the software.
|
|
|
|
-TZDIR= $(TOPDIR)/etc/zoneinfo
|
|
+TZDIR= $(TOPDIR)/share/zoneinfo
|
|
|
|
# The "tzselect", "zic", and "zdump" commands get installed in. . .
|
|
|
|
-ETCDIR= $(TOPDIR)/etc
|
|
+SBINDIR= $(TOPDIR)/sbin
|
|
|
|
# If you "make INSTALL", the "date" command gets installed in. . .
|
|
|
|
@@ -52,7 +52,7 @@
|
|
|
|
# Manual pages go in subdirectories of. . .
|
|
|
|
-MANDIR= $(TOPDIR)/man
|
|
+MANDIR= $(TOPDIR)/share/man
|
|
|
|
# Library functions are put in an archive in LIBDIR.
|
|
|
|
@@ -83,7 +83,7 @@
|
|
|
|
# Non-default libraries needed to link.
|
|
# Add -lintl if you want to use `gettext' on Solaris.
|
|
-LDLIBS=
|
|
+LDLIBS=$(LDFLAGS)
|
|
|
|
# Add the following to the end of the "CFLAGS=" line as needed.
|
|
# -Dconst= if `const' does not work (SunOS 4.x cc, OSF1 V5.0 cc)
|
|
@@ -211,7 +211,7 @@
|
|
# before the first Monday in January when a "%V" format is used and January 1
|
|
# falls on a Friday, Saturday, or Sunday.
|
|
|
|
-CFLAGS=
|
|
+CFLAGS += -std=gnu99
|
|
|
|
# If you want zic's -s option used when installing, uncomment the next line
|
|
# ZFLAGS= -s
|
|
@@ -220,7 +220,7 @@
|
|
ZIC= $(zic) $(ZFLAGS)
|
|
|
|
# The name of a Posix-compliant `awk' on your system.
|
|
-AWK= nawk
|
|
+AWK= awk
|
|
|
|
# The path where SGML DTDs are kept.
|
|
SGML_SEARCH_PATH= $(TOPDIR)/share/doc/sgml-lib/REC-html401-19991224/
|
|
@@ -241,8 +241,10 @@
|
|
|
|
###############################################################################
|
|
|
|
-cc= cc
|
|
-CC= $(cc) -DTZDIR=\"$(TZDIR)\"
|
|
+CC+= -DTZDIR=\"$(TZDIR)\"
|
|
+ifeq ($(NLS),1)
|
|
+CC += -DHAVE_GETTEXT=1 -DTZ_DOMAIN=\"libc\"
|
|
+endif
|
|
|
|
TZCSRCS= zic.c localtime.c asctime.c scheck.c ialloc.c
|
|
TZCOBJS= zic.o localtime.o asctime.o scheck.o ialloc.o
|
|
@@ -282,14 +284,16 @@
|
|
|
|
ALL: all date
|
|
|
|
-install: all $(DATA) $(REDO) $(TZLIB) $(MANS) $(TABDATA)
|
|
+install: all $(DATA) $(REDO) $(MANS) $(TABDATA)
|
|
$(ZIC) -y $(YEARISTYPE) \
|
|
-d $(TZDIR) -l $(LOCALTIME) -p $(POSIXRULES)
|
|
-rm -f $(TZDIR)/iso3166.tab $(TZDIR)/zone.tab
|
|
cp iso3166.tab zone.tab $(TZDIR)/.
|
|
- -mkdir $(TOPDIR) $(ETCDIR)
|
|
- cp tzselect zic zdump $(ETCDIR)/.
|
|
- -mkdir $(TOPDIR) $(MANDIR) \
|
|
+ -mkdir -p $(TOPDIR) $(SBINDIR)
|
|
+ cp zic zdump $(SBINDIR)/.
|
|
+ -mkdir -p $(TOPDIR) $(BINDIR)
|
|
+ cp tzselect $(BINDIR)/.
|
|
+ -mkdir -p $(TOPDIR) $(MANDIR) \
|
|
$(MANDIR)/man3 $(MANDIR)/man5 $(MANDIR)/man8
|
|
-rm -f $(MANDIR)/man3/newctime.3 \
|
|
$(MANDIR)/man3/newtzset.3 \
|
|
@@ -298,13 +302,11 @@
|
|
$(MANDIR)/man8/zdump.8 \
|
|
$(MANDIR)/man8/zic.8
|
|
cp newctime.3 newtzset.3 $(MANDIR)/man3/.
|
|
- cp tzfile.5 $(MANDIR)/man5/.
|
|
- cp tzselect.8 zdump.8 zic.8 $(MANDIR)/man8/.
|
|
|
|
INSTALL: ALL install date.1
|
|
- -mkdir $(TOPDIR) $(BINDIR)
|
|
+ -mkdir -p $(TOPDIR) $(BINDIR)
|
|
cp date $(BINDIR)/.
|
|
- -mkdir $(TOPDIR) $(MANDIR) $(MANDIR)/man1
|
|
+ -mkdir -p $(TOPDIR) $(MANDIR) $(MANDIR)/man1
|
|
-rm -f $(MANDIR)/man1/date.1
|
|
cp date.1 $(MANDIR)/man1/.
|
|
|
|
@@ -334,9 +336,9 @@
|
|
# You must replace all of $(TZDIR) to switch from not using leap seconds
|
|
# to using them, or vice versa.
|
|
other_two: zic leapseconds $(TDATA)
|
|
- $(ZIC) -y $(YEARISTYPE) -d $(TZDIR)-posix -L /dev/null $(TDATA)
|
|
+ $(ZIC) -y $(YEARISTYPE) -d $(TZDIR)/posix -L /dev/null $(TDATA)
|
|
$(ZIC) -y $(YEARISTYPE) \
|
|
- -d $(TZDIR)-leaps -L leapseconds $(TDATA)
|
|
+ -d $(TZDIR)/right -L leapseconds $(TDATA)
|
|
|
|
posix_right: posix_only other_two
|
|
|
|
@@ -367,7 +369,7 @@
|
|
<$? >$@
|
|
chmod +x $@
|
|
|
|
-check: check_tables check_web
|
|
+check: check_tables
|
|
|
|
check_tables: checktab.awk $(PRIMARY_YDATA)
|
|
$(AWK) -f checktab.awk $(PRIMARY_YDATA)
|
|
diff -Naur src/tzselect.ksh src-p/tzselect.ksh
|
|
--- src/tzselect.ksh 2007-08-20 16:47:42.000000000 +0200
|
|
+++ src-p/tzselect.ksh 2007-10-02 04:07:44.000000000 +0200
|
|
@@ -1,4 +1,4 @@
|
|
-#! /bin/ksh
|
|
+#! /bin/bash
|
|
|
|
# '@(#)tzselect.ksh 8.1'
|
|
|