mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
32 lines
1.2 KiB
Diff
32 lines
1.2 KiB
Diff
From dc817a2061699cd1f33ca93f0d93a1fbc2f33ea1 Mon Sep 17 00:00:00 2001
|
|
From: Allan McRae <allan@archlinux.org>
|
|
Date: Thu, 17 Jun 2010 14:32:08 +1000
|
|
Subject: [PATCH] makepkg: fallback to sane defaults for library stripping
|
|
|
|
If the library stripping variables are not defined in makepkg.conf,
|
|
libraries will be fully stripped and become broken. Fallback to a
|
|
sane default stripping level.
|
|
|
|
Signed-off-by: Allan McRae <allan@archlinux.org>
|
|
Signed-off-by: Dan McGee <dan@archlinux.org>
|
|
---
|
|
scripts/makepkg.sh.in | 3 +++
|
|
1 files changed, 3 insertions(+), 0 deletions(-)
|
|
|
|
diff --git a/scripts/makepkg.sh.in b/scripts/makepkg.sh.in
|
|
index d986701..e64b564 100644
|
|
--- a/scripts/makepkg.sh.in
|
|
+++ b/scripts/makepkg.sh.in
|
|
@@ -864,6 +864,9 @@ tidy_install() {
|
|
|
|
if [[ $(check_option strip) = y && -n ${STRIP_DIRS[*]} ]]; then
|
|
msg2 "$(gettext "Stripping unneeded symbols from binaries and libraries...")"
|
|
+ # make sure library stripping variables are defined to prevent excess stripping
|
|
+ [[ -z ${STRIP_SHARED+x} ]] && STRIP_SHARED="-S"
|
|
+ [[ -z ${STRIP_STATIC+x} ]] && STRIP_STATIC="-S"
|
|
local binary
|
|
find ${STRIP_DIRS[@]} -type f -perm -u+w 2>/dev/null | while read binary ; do
|
|
case "$(file -bi "$binary")" in
|
|
--
|
|
1.7.1
|
|
|