mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
114 lines
5.2 KiB
Diff
114 lines
5.2 KiB
Diff
diff -Naur uuid-1.6.2.orig/Makefile.in uuid-1.6.2/Makefile.in
|
|
--- uuid-1.6.2.orig/Makefile.in 2010-12-21 08:27:31.550117859 -0700
|
|
+++ uuid-1.6.2/Makefile.in 2010-12-21 08:50:36.578086743 -0700
|
|
@@ -62,13 +62,13 @@
|
|
PHP = @PHP@
|
|
PG_CONFIG = @PG_CONFIG@
|
|
|
|
-LIB_NAME = libuuid.la
|
|
+LIB_NAME = libossp-uuid.la
|
|
LIB_OBJS = uuid.lo uuid_md5.lo uuid_sha1.lo uuid_prng.lo uuid_mac.lo uuid_time.lo uuid_ui64.lo uuid_ui128.lo uuid_str.lo
|
|
|
|
-DCE_NAME = libuuid_dce.la
|
|
+DCE_NAME = libossp-uuid_dce.la
|
|
DCE_OBJS = uuid_dce.lo $(LIB_OBJS)
|
|
|
|
-CXX_NAME = libuuid++.la
|
|
+CXX_NAME = libossp-uuid++.la
|
|
CXX_OBJS = uuid++.lo $(LIB_OBJS)
|
|
|
|
PRG_NAME = uuid
|
|
@@ -231,7 +231,7 @@
|
|
$(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(mandir)/man1
|
|
$(SHTOOL) install -c -m 755 uuid-config $(DESTDIR)$(bindir)/
|
|
$(SHTOOL) install -c -m 644 $(S)/uuid-config.1 $(DESTDIR)$(mandir)/man1/
|
|
- $(SHTOOL) install -c -m 644 $(S)/uuid.pc $(DESTDIR)$(libdir)/pkgconfig/
|
|
+ $(SHTOOL) install -c -m 644 $(S)/uuid.pc $(DESTDIR)$(libdir)/pkgconfig/ossp-uuid.pc
|
|
$(SHTOOL) install -c -m 644 uuid.h $(DESTDIR)$(includedir)/
|
|
-@if [ ".$(WITH_DCE)" = .yes ]; then \
|
|
echo "$(SHTOOL) install -c -m 644 $(S)/uuid_dce.h $(DESTDIR)$(includedir)/"; \
|
|
@@ -241,7 +241,7 @@
|
|
echo "$(SHTOOL) install -c -m 644 $(S)/uuid++.hh $(DESTDIR)$(includedir)/"; \
|
|
$(SHTOOL) install -c -m 644 $(S)/uuid++.hh $(DESTDIR)$(includedir)/; \
|
|
fi
|
|
- $(SHTOOL) install -c -m 644 $(S)/uuid.3 $(DESTDIR)$(mandir)/man3/
|
|
+ $(SHTOOL) install -c -m 644 $(S)/uuid.3 $(DESTDIR)$(mandir)/man3/ossp-uuid.3
|
|
-@if [ ".$(WITH_CXX)" = .yes ]; then \
|
|
echo "$(SHTOOL) install -c -m 644 $(S)/uuid++.3 $(DESTDIR)$(mandir)/man3/"; \
|
|
$(SHTOOL) install -c -m 644 $(S)/uuid++.3 $(DESTDIR)$(mandir)/man3/; \
|
|
@@ -276,7 +276,7 @@
|
|
-@if [ ".$(WITH_CXX)" = .yes ]; then \
|
|
$(LIBTOOL) --mode=uninstall $(RM) $(DESTDIR)$(libdir)/$(CXX_NAME); \
|
|
fi
|
|
- -$(RM) $(DESTDIR)$(mandir)/man3/uuid.3
|
|
+ -$(RM) $(DESTDIR)$(mandir)/man3/ossp-uuid.3
|
|
-@if [ ".$(WITH_CXX)" = .yes ]; then \
|
|
echo "$(RM) $(DESTDIR)$(mandir)/man3/uuid++.3"; \
|
|
$(RM) $(DESTDIR)$(mandir)/man3/uuid++.3; \
|
|
@@ -290,7 +290,7 @@
|
|
echo "$(RM) $(DESTDIR)$(includedir)/uuid++.hh"; \
|
|
$(RM) $(DESTDIR)$(includedir)/uuid++.hh; \
|
|
fi
|
|
- -$(RM) $(DESTDIR)$(libdir)/pkgconfig/uuid.pc
|
|
+ -$(RM) $(DESTDIR)$(libdir)/pkgconfig/ossp-uuid.pc
|
|
-$(RM) $(DESTDIR)$(mandir)/man1/uuid-config.1
|
|
-$(RM) $(DESTDIR)$(bindir)/uuid-config
|
|
-$(RMDIR) $(DESTDIR)$(mandir)/man1 >/dev/null 2>&1 || $(TRUE)
|
|
diff --git a/perl/Makefile.PL b/perl/Makefile.PL
|
|
index 92f4494..9c6fee6 100644
|
|
--- a/perl/Makefile.PL
|
|
+++ b/perl/Makefile.PL
|
|
@@ -33,9 +33,9 @@ use Config;
|
|
use ExtUtils::MakeMaker;
|
|
|
|
# determine source directory
|
|
-my ($srcdir) = map { my $d = $_; $d =~ s/\/libuuid\.la$//; $d }
|
|
- grep { -f $_ } ("../libuuid.la", glob("../*/libuuid.la"))
|
|
- or die "no source directory found (where libuuid.la is located)";
|
|
+my ($srcdir) = map { my $d = $_; $d =~ s/\/libossp-uuid\.la$//; $d }
|
|
+ grep { -f $_ } ("../libossp-uuid.la", glob("../*/libossp-uuid.la"))
|
|
+ or die "no source directory found (where libossp-uuid.la is located)";
|
|
|
|
# determine extra build options
|
|
my $compat = 0;
|
|
@@ -47,15 +47,15 @@ WriteMakefile(
|
|
VERSION_FROM => 'uuid.pm',
|
|
ABSTRACT_FROM => 'uuid.pod',
|
|
PREREQ_PM => {},
|
|
- LIBS => [ "-L$srcdir/.libs -L$srcdir -luuid" ],
|
|
+ LIBS => [ "-L$srcdir/.libs -L$srcdir -lossp-uuid" ],
|
|
DEFINE => '',
|
|
INC => "-I. -I$srcdir",
|
|
PM => { 'uuid.pm' => '$(INST_LIBDIR)/uuid.pm',
|
|
'uuid.pod' => '$(INST_LIBDIR)/uuid.pod',
|
|
($compat ? ('uuid_compat.pm' => '$(INST_LIBDIR)/../Data/UUID.pm') : ()),
|
|
($compat ? ('uuid_compat.pod' => '$(INST_LIBDIR)/../Data/UUID.pod') : ()), },
|
|
- MAN3PODS => { 'uuid.pod' => '$(INST_MAN3DIR)/OSSP::uuid.3',
|
|
- ($compat ? ('uuid_compat.pod' => '$(INST_MAN3DIR)/Data::UUID.3') : ()), },
|
|
+ MAN3PODS => { 'uuid.pod' => '$(INST_MAN3DIR)/OSSP::uuid.3pm',
|
|
+ ($compat ? ('uuid_compat.pod' => '$(INST_MAN3DIR)/Data::UUID.3pm') : ()), },
|
|
TYPEMAPS => [ 'uuid.tm' ],
|
|
test => { TESTS => 'uuid.ts' . ($compat ? ' uuid_compat.ts' : '') },
|
|
NO_META => 1,
|
|
diff -Naur uuid-1.6.2.orig/uuid-config.in uuid-1.6.2/uuid-config.in
|
|
--- uuid-1.6.2.orig/uuid-config.in 2010-12-21 08:27:31.546784588 -0700
|
|
+++ uuid-1.6.2/uuid-config.in 2010-12-21 08:48:38.170684057 -0700
|
|
@@ -121,7 +121,7 @@
|
|
output_extra="$output_extra $uuid_ldflags"
|
|
;;
|
|
--libs)
|
|
- output="$output -luuid"
|
|
+ output="$output -lossp-uuid"
|
|
output_extra="$output_extra $uuid_libs"
|
|
;;
|
|
* )
|
|
diff -Naur uuid-1.6.2.orig/uuid.pc.in uuid-1.6.2/uuid.pc.in
|
|
--- uuid-1.6.2.orig/uuid.pc.in 2010-12-21 08:27:31.546784588 -0700
|
|
+++ uuid-1.6.2/uuid.pc.in 2010-12-21 08:48:38.174017223 -0700
|
|
@@ -37,6 +37,6 @@
|
|
Version: @UUID_VERSION_RAW@
|
|
URL: http://www.ossp.org/pkg/lib/uuid/
|
|
Cflags: -I${includedir}
|
|
-Libs: -L${libdir} -luuid
|
|
+Libs: -L${libdir} -lossp-uuid
|
|
Libs.private: @LIBS@
|