mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
38 lines
1.1 KiB
Diff
38 lines
1.1 KiB
Diff
From 4a5181de15e0a299aeb75a818410ddb2d584cec0 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Fri, 25 Nov 2016 22:15:09 -0700
|
|
Subject: [PATCH 09/11] add vframe_provider_s definition
|
|
|
|
---
|
|
arch/arm/include/asm/arch-m8b/osd_hw_def.h | 8 ++++++++
|
|
1 file changed, 8 insertions(+)
|
|
|
|
diff --git a/arch/arm/include/asm/arch-m8b/osd_hw_def.h b/arch/arm/include/asm/arch-m8b/osd_hw_def.h
|
|
index c24301d..a777221 100644
|
|
--- a/arch/arm/include/asm/arch-m8b/osd_hw_def.h
|
|
+++ b/arch/arm/include/asm/arch-m8b/osd_hw_def.h
|
|
@@ -1,6 +1,7 @@
|
|
#ifndef _OSD_HW_DEF_H
|
|
#define _OSD_HW_DEF_H
|
|
#include <asm/arch/osd_hw.h>
|
|
+#include <linux/list.h>
|
|
|
|
/************************************************************************
|
|
**
|
|
@@ -206,6 +207,13 @@ typedef struct vframe_operations_s {
|
|
int (*vf_states)(vframe_states_t *states, void* op_arg);
|
|
} vframe_operations_t;
|
|
|
|
+typedef struct vframe_provider_s {
|
|
+ const char *name;
|
|
+ const struct vframe_operations_s *ops;
|
|
+ void* op_arg;
|
|
+ struct list_head list;
|
|
+} vframe_provider_t;
|
|
+
|
|
/************************************************************************
|
|
**
|
|
** func declare part
|
|
--
|
|
2.10.2
|
|
|