mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
57 lines
1.8 KiB
Diff
57 lines
1.8 KiB
Diff
diff --git a/drivers/net/wireless/ti/wl12xx/main.c b/drivers/net/wireless/ti/wl12xx/main.c
|
|
index 0b11029..cadd7f3 100644
|
|
--- a/drivers/net/wireless/ti/wl12xx/main.c
|
|
+++ b/drivers/net/wireless/ti/wl12xx/main.c
|
|
@@ -1394,22 +1394,6 @@ static u32 wl12xx_sta_get_ap_rate_mask(struct wl1271 *wl,
|
|
return wlvif->rate_set;
|
|
}
|
|
|
|
-static int wl12xx_identify_fw(struct wl1271 *wl)
|
|
-{
|
|
- unsigned int *fw_ver = wl->chip.fw_ver;
|
|
-
|
|
- /* Only new station firmwares support routing fw logs to the host */
|
|
- if ((fw_ver[FW_VER_IF_TYPE] == FW_VER_IF_TYPE_STA) &&
|
|
- (fw_ver[FW_VER_MINOR] < FW_VER_MINOR_FWLOG_STA_MIN))
|
|
- wl->quirks |= WLCORE_QUIRK_FWLOG_NOT_IMPLEMENTED;
|
|
-
|
|
- /* This feature is not yet supported for AP mode */
|
|
- if (fw_ver[FW_VER_IF_TYPE] == FW_VER_IF_TYPE_AP)
|
|
- wl->quirks |= WLCORE_QUIRK_FWLOG_NOT_IMPLEMENTED;
|
|
-
|
|
- return 0;
|
|
-}
|
|
-
|
|
static void wl12xx_conf_init(struct wl1271 *wl)
|
|
{
|
|
struct wl12xx_priv *priv = wl->priv;
|
|
@@ -1594,7 +1578,6 @@ static int wl12xx_setup(struct wl1271 *wl);
|
|
static struct wlcore_ops wl12xx_ops = {
|
|
.setup = wl12xx_setup,
|
|
.identify_chip = wl12xx_identify_chip,
|
|
- .identify_fw = wl12xx_identify_fw,
|
|
.boot = wl12xx_boot,
|
|
.plt_init = wl12xx_plt_init,
|
|
.trigger_cmd = wl12xx_trigger_cmd,
|
|
diff --git a/drivers/net/wireless/ti/wlcore/wlcore_i.h b/drivers/net/wireless/ti/wlcore/wlcore_i.h
|
|
index 6678d4b..dbbfca1 100644
|
|
--- a/drivers/net/wireless/ti/wlcore/wlcore_i.h
|
|
+++ b/drivers/net/wireless/ti/wlcore/wlcore_i.h
|
|
@@ -109,17 +109,6 @@ enum {
|
|
NUM_FW_VER
|
|
};
|
|
|
|
-#define FW_VER_CHIP_WL127X 6
|
|
-#define FW_VER_CHIP_WL128X 7
|
|
-
|
|
-#define FW_VER_IF_TYPE_STA 1
|
|
-#define FW_VER_IF_TYPE_AP 2
|
|
-
|
|
-#define FW_VER_MINOR_1_SPARE_STA_MIN 58
|
|
-#define FW_VER_MINOR_1_SPARE_AP_MIN 47
|
|
-
|
|
-#define FW_VER_MINOR_FWLOG_STA_MIN 70
|
|
-
|
|
struct wl1271_chip {
|
|
u32 id;
|
|
char fw_ver_str[ETHTOOL_BUSINFO_LEN];
|