mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
52 lines
2.6 KiB
Diff
52 lines
2.6 KiB
Diff
diff -Naur net-tools-1.60-orig/config.in net-tools-1.60/config.in
|
|
--- net-tools-1.60-orig/config.in 2000-05-21 07:32:12.000000000 -0700
|
|
+++ net-tools-1.60/config.in 2004-05-31 12:36:00.000000000 -0700
|
|
@@ -49,7 +49,7 @@
|
|
*
|
|
bool 'UNIX protocol family' HAVE_AFUNIX y
|
|
bool 'INET (TCP/IP) protocol family' HAVE_AFINET y
|
|
-bool 'INET6 (IPv6) protocol family' HAVE_AFINET6 n
|
|
+bool 'INET6 (IPv6) protocol family' HAVE_AFINET6 y
|
|
bool 'Novell IPX/SPX protocol family' HAVE_AFIPX y
|
|
bool 'Appletalk DDP protocol family' HAVE_AFATALK y
|
|
bool 'AX25 (packet radio) protocol family' HAVE_AFAX25 y
|
|
@@ -86,6 +86,6 @@
|
|
*
|
|
* Other Features.
|
|
*
|
|
-bool 'IP Masquerading support' HAVE_FW_MASQUERADE n
|
|
-bool 'Build iptunnel and ipmaddr' HAVE_IP_TOOLS n
|
|
-bool 'Build mii-tool' HAVE_MII n
|
|
+bool 'IP Masquerading support' HAVE_FW_MASQUERADE y
|
|
+bool 'Build iptunnel and ipmaddr' HAVE_IP_TOOLS y
|
|
+bool 'Build mii-tool' HAVE_MII y
|
|
diff -Naur net-tools-1.60-orig/mii-tool.c net-tools-1.60/mii-tool.c
|
|
--- net-tools-1.60-orig/mii-tool.c 2000-05-21 07:31:17.000000000 -0700
|
|
+++ net-tools-1.60/mii-tool.c 2004-05-31 12:35:21.000000000 -0700
|
|
@@ -379,16 +379,16 @@
|
|
/*--------------------------------------------------------------------*/
|
|
|
|
const char *usage =
|
|
-"usage: %s [-VvRrwl] [-A media,... | -F media] [interface ...]
|
|
- -V, --version display version information
|
|
- -v, --verbose more verbose output
|
|
- -R, --reset reset MII to poweron state
|
|
- -r, --restart restart autonegotiation
|
|
- -w, --watch monitor for link status changes
|
|
- -l, --log with -w, write events to syslog
|
|
- -A, --advertise=media,... advertise only specified media
|
|
- -F, --force=media force specified media technology
|
|
-media: 100baseT4, 100baseTx-FD, 100baseTx-HD, 10baseT-FD, 10baseT-HD,
|
|
+"usage: %s [-VvRrwl] [-A media,... | -F media] [interface ...]\n\
|
|
+ -V, --version display version information\n\
|
|
+ -v, --verbose more verbose output\n\
|
|
+ -R, --reset reset MII to poweron state\n\
|
|
+ -r, --restart restart autonegotiation\n\
|
|
+ -w, --watch monitor for link status changes\n\
|
|
+ -l, --log with -w, write events to syslog\n\
|
|
+ -A, --advertise=media,... advertise only specified media\n\
|
|
+ -F, --force=media force specified media technology\n\
|
|
+media: 100baseT4, 100baseTx-FD, 100baseTx-HD, 10baseT-FD, 10baseT-HD,\n\
|
|
(to advertise both HD and FD) 100baseTx, 10baseT\n";
|
|
|
|
int main(int argc, char **argv)
|