mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
44 lines
1.8 KiB
Diff
44 lines
1.8 KiB
Diff
commit 45cfc51681287482c8b9843a20d6b4d06555ff62
|
|
Author: Stanislaw Gruszka <sgruszka@redhat.com>
|
|
Date: Fri Jan 31 13:18:09 2014 +0100
|
|
|
|
rt2x00: move frequent messages to debug level
|
|
|
|
On commit 28f2bce9f8bbf704c86f8c684337f82c51592c81 I make change that
|
|
print various messages as default. This can cause flood of messages
|
|
related to TX status timeout on some environments. I partially fixed
|
|
problem on commit bb9c298f3193ac5b80e47b325c690700580b6bcf, but forgot
|
|
to move two more messages to debug level.
|
|
|
|
Signed-off-by: Stanislaw Gruszka <sgruszka@redhat.com>
|
|
Acked-by: Gertjan van Wingerde <gwingerde@gmail.com>
|
|
Signed-off-by: John W. Linville <linville@tuxdriver.com>
|
|
|
|
diff --git a/drivers/net/wireless/rt2x00/rt2800usb.c b/drivers/net/wireless/rt2x00/rt2800usb.c
|
|
index caddc1b..14a90dd 100644
|
|
--- a/drivers/net/wireless/rt2x00/rt2800usb.c
|
|
+++ b/drivers/net/wireless/rt2x00/rt2800usb.c
|
|
@@ -125,9 +125,9 @@ static inline bool rt2800usb_entry_txstatus_timeout(struct queue_entry *entry)
|
|
|
|
tout = time_after(jiffies, entry->last_action + msecs_to_jiffies(100));
|
|
if (unlikely(tout))
|
|
- rt2x00_warn(entry->queue->rt2x00dev,
|
|
- "TX status timeout for entry %d in queue %d\n",
|
|
- entry->entry_idx, entry->queue->qid);
|
|
+ rt2x00_dbg(entry->queue->rt2x00dev,
|
|
+ "TX status timeout for entry %d in queue %d\n",
|
|
+ entry->entry_idx, entry->queue->qid);
|
|
return tout;
|
|
|
|
}
|
|
@@ -566,8 +566,8 @@ static void rt2800usb_txdone(struct rt2x00_dev *rt2x00dev)
|
|
queue = rt2x00queue_get_tx_queue(rt2x00dev, qid);
|
|
|
|
if (unlikely(rt2x00queue_empty(queue))) {
|
|
- rt2x00_warn(rt2x00dev, "Got TX status for an empty queue %u, dropping\n",
|
|
- qid);
|
|
+ rt2x00_dbg(rt2x00dev, "Got TX status for an empty queue %u, dropping\n",
|
|
+ qid);
|
|
break;
|
|
}
|
|
|