PKGBUILDs/extra/dhcp/dhclient-script-pathFixes.patch

119 lines
4.3 KiB
Diff

--- linux 2009-04-21 16:21:09.000000000 +0200
+++ linux_new 2010-06-30 19:06:20.000000000 +0200
@@ -23,7 +23,7 @@
# of the $1 in its args.
# 'ip' just looks too weird. /sbin/ip looks less weird.
-ip=/sbin/ip
+ip=/usr/sbin/ip
make_resolv_conf() {
if [ x"$new_domain_name_servers" != x ]; then
@@ -112,9 +112,9 @@
if [ x$reason = xPREINIT ]; then
if [ x$alias_ip_address != x ]; then
# Bring down alias interface. Its routes will disappear too.
- ifconfig $interface:0- inet 0
+ /sbin/ifconfig $interface:0- inet 0
fi
- ifconfig $interface 0 up
+ /sbin/ifconfig $interface 0 up
# We need to give the kernel some time to get the interface up.
sleep 1
@@ -141,32 +141,32 @@
if [ x$old_ip_address != x ] && [ x$alias_ip_address != x ] && \
[ x$alias_ip_address != x$old_ip_address ]; then
# Possible new alias. Remove old alias.
- ifconfig $interface:0- inet 0
+ /sbin/ifconfig $interface:0- inet 0
fi
if [ x$old_ip_address != x ] && [ x$old_ip_address != x$new_ip_address ]; then
# IP address changed. Bringing down the interface will delete all routes,
# and clear the ARP cache.
- ifconfig $interface inet 0 down
+ /sbin/ifconfig $interface inet 0 down
fi
if [ x$old_ip_address = x ] || [ x$old_ip_address != x$new_ip_address ] || \
[ x$reason = xBOUND ] || [ x$reason = xREBOOT ]; then
- ifconfig $interface inet $new_ip_address $new_subnet_arg \
+ /sbin/ifconfig $interface inet $new_ip_address $new_subnet_arg \
$new_broadcast_arg $mtu_arg
# Add a network route to the computed network address.
for router in $new_routers; do
if [ "x$new_subnet_mask" = "x255.255.255.255" ] ; then
- route add -host $router dev $interface
+ /sbin/route add -host $router dev $interface
fi
- route add default gw $router $metric_arg dev $interface
+ /sbin/route add default gw $router $metric_arg dev $interface
done
fi
if [ x$new_ip_address != x$alias_ip_address ] && [ x$alias_ip_address != x ];
then
- ifconfig $interface:0- inet 0
- ifconfig $interface:0 inet $alias_ip_address $alias_subnet_arg
- route add -host $alias_ip_address $interface:0
+ /sbin/ifconfig $interface:0- inet 0
+ /sbin/ifconfig $interface:0 inet $alias_ip_address $alias_subnet_arg
+ /sbin/route add -host $alias_ip_address $interface:0
fi
make_resolv_conf
exit_with_hooks 0
@@ -176,42 +176,42 @@
|| [ x$reason = xSTOP ]; then
if [ x$alias_ip_address != x ]; then
# Turn off alias interface.
- ifconfig $interface:0- inet 0
+ /sbin/ifconfig $interface:0- inet 0
fi
if [ x$old_ip_address != x ]; then
# Shut down interface, which will delete routes and clear arp cache.
- ifconfig $interface inet 0 down
+ /sbin/ifconfig $interface inet 0 down
fi
if [ x$alias_ip_address != x ]; then
- ifconfig $interface:0 inet $alias_ip_address $alias_subnet_arg
- route add -host $alias_ip_address $interface:0
+ /sbin/ifconfig $interface:0 inet $alias_ip_address $alias_subnet_arg
+ /sbin/route add -host $alias_ip_address $interface:0
fi
exit_with_hooks 0
fi
if [ x$reason = xTIMEOUT ]; then
if [ x$alias_ip_address != x ]; then
- ifconfig $interface:0- inet 0
+ /sbin/ifconfig $interface:0- inet 0
fi
- ifconfig $interface inet $new_ip_address $new_subnet_arg \
+ /sbin/ifconfig $interface inet $new_ip_address $new_subnet_arg \
$new_broadcast_arg $mtu_arg
set $new_routers
if ping -q -c 1 $1; then
if [ x$new_ip_address != x$alias_ip_address ] && \
[ x$alias_ip_address != x ]; then
- ifconfig $interface:0 inet $alias_ip_address $alias_subnet_arg
- route add -host $alias_ip_address dev $interface:0
+ /sbin/ifconfig $interface:0 inet $alias_ip_address $alias_subnet_arg
+ /sbin/route add -host $alias_ip_address dev $interface:0
fi
for router in $new_routers; do
if [ "x$new_subnet_mask" = "x255.255.255.255" ] ; then
- route add -host $router dev $interface
+ /sbin/route add -host $router dev $interface
fi
- route add default gw $router $metric_arg dev $interface
+ /sbin/route add default gw $router $metric_arg dev $interface
done
make_resolv_conf
exit_with_hooks 0
fi
- ifconfig $interface inet 0 down
+ /sbin/ifconfig $interface inet 0 down
exit_with_hooks 1
fi