mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
16 lines
367 B
Diff
16 lines
367 B
Diff
the OPEN_MAX define has been removed in newer kernel headers so use the
|
|
proper method of getting the value dynamically
|
|
|
|
http://bugs.gentoo.org/195861
|
|
|
|
--- a/rdisc.c
|
|
+++ b/rdisc.c
|
|
@@ -247,7 +247,7 @@ void do_fork(void)
|
|
if ((pid=fork()) != 0)
|
|
exit(0);
|
|
|
|
- for (t = 0; t < OPEN_MAX; t++)
|
|
+ for (t = 0; t < sysconf(_SC_OPEN_MAX); t++)
|
|
if (t != s)
|
|
close(t);
|
|
|