mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
bda45916e1
and check dtbs dir for dtb file
22 lines
805 B
Diff
22 lines
805 B
Diff
diff --git a/arch/arm/cpu/armv7/config.mk b/arch/arm/cpu/armv7/config.mk
|
|
index d01f3d9..c048531 100644
|
|
--- a/arch/arm/cpu/armv7/config.mk
|
|
+++ b/arch/arm/cpu/armv7/config.mk
|
|
@@ -10,9 +10,12 @@
|
|
PF_CPPFLAGS_ARMV7 := $(call cc-option, -march=armv7-a, -march=armv5)
|
|
PLATFORM_CPPFLAGS += $(PF_CPPFLAGS_ARMV7)
|
|
|
|
-# SEE README.arm-unaligned-accesses
|
|
+# On supported platforms we set the bit which causes us to trap on unaligned
|
|
+# memory access. This is the opposite of what the compiler expects to be
|
|
+# the default so we must pass in -mno-unaligned-access so that it is aware
|
|
+# of our decision.
|
|
PF_NO_UNALIGNED := $(call cc-option, -mno-unaligned-access,)
|
|
-PLATFORM_NO_UNALIGNED := $(PF_NO_UNALIGNED)
|
|
+PLATFORM_CPPFLAGS += $(PF_NO_UNALIGNED)
|
|
|
|
ifneq ($(CONFIG_IMX_CONFIG),)
|
|
ifdef CONFIG_SPL
|
|
--
|
|
1.7.9.5
|
|
|