extra/qt6-base to 6.0.1-2

This commit is contained in:
Kevin Mihelich 2021-02-10 22:31:04 +00:00
parent f631888800
commit 0508e85a23
2 changed files with 19 additions and 3 deletions

View file

@ -8,7 +8,7 @@
pkgname=qt6-base
_qtver=6.0.1
pkgver=${_qtver/-/}
pkgrel=1
pkgrel=2
arch=(x86_64)
url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
@ -28,12 +28,15 @@ optdepends=('postgresql-libs: PostgreSQL driver'
groups=(qt6)
_pkgfn="${pkgname/6-/}-everywhere-src-${_qtver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz"
qt6-base-cflags.patch)
qt6-base-cflags.patch
qt6-base-nostrip.patch)
sha256sums=('8d2bc1829c1479e539f66c2f51a7e11c38a595c9e8b8e45a3b45f3cb41c6d6aa'
'cf707cd970650f8b60f8897692b36708ded9ba116723ec8fcd885576783fe85c')
'cf707cd970650f8b60f8897692b36708ded9ba116723ec8fcd885576783fe85c'
'4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094')
prepare() {
patch -d $_pkgfn -p1 -i ../qt6-base-cflags.patch # Use system CFLAGS
patch -d $_pkgfn -p1 -i ../qt6-base-nostrip.patch # Don't strip binaries with qmake
}
build() {

View file

@ -0,0 +1,13 @@
diff --git a/mkspecs/common/gcc-base.conf b/mkspecs/common/gcc-base.conf
index 99d77156fd..fc840fe9f6 100644
--- a/mkspecs/common/gcc-base.conf
+++ b/mkspecs/common/gcc-base.conf
@@ -31,6 +31,8 @@
# you can use the manual test in tests/manual/mkspecs.
#
+CONFIG += nostrip
+
QMAKE_CFLAGS_OPTIMIZE = -O2
QMAKE_CFLAGS_OPTIMIZE_FULL = -O3
QMAKE_CFLAGS_OPTIMIZE_DEBUG = -Og