Modded core PKGBUILDs for ARM

This commit is contained in:
Mike Staszel 2009-10-10 00:36:41 -05:00
parent 03ab385447
commit 0d5b9a0c8d
6 changed files with 13 additions and 98 deletions

View file

@ -1,23 +1,19 @@
# $Id: PKGBUILD 38691 2009-05-10 06:48:07Z tpowa $
# Maintainer: judd <jvinet@zeroflux.org>
pkgname=bin86
pkgver=0.16.17
pkgrel=4
pkgdesc="A complete 8086 assembler and loader"
arch=(i686 x86_64)
arch=('arm')
license=('GPL')
url="http://www.debath.co.uk/"
groups=('base-devel')
depends=('glibc')
source=(http://homepage.ntlworld.com/robert.debath/dev86/$pkgname-$pkgver.tar.gz
bin86-0.16.17-x86_64-1.patch)
md5sums=('c9e8d72dd2e7457b52d0e3164fc199a1' '92bdce7b0655cd2e9f83c83fc56d128e')
source=(http://homepage.ntlworld.com/robert.debath/dev86/$pkgname-$pkgver.tar.gz)
md5sums=('c9e8d72dd2e7457b52d0e3164fc199a1')
build() {
cd $srcdir/$pkgname-$pkgver
if [ "$CARCH" = "x86_64" ]; then
patch -Np1 -i ../bin86-0.16.17-x86_64-1.patch || return 1
fi
make PREFIX=/usr || return 1
mkdir -p $pkgdir/usr/bin $pkgdir/usr/share/man/man1
make PREFIX=$pkgdir/usr MANDIR=$pkgdir/usr/share/man/man1 install

View file

@ -1,44 +0,0 @@
Submitted By: Ken Moffat <ken@kenmoffat.uklinux.net>
Date: 2005-06-28
Initial Package Version: 0.16.14
Upstream Status: Submitted Upstream
Origin: from ROCK Linux
Description: Allows bin86 to compile on x86_64, which permits lilo to
be used in a 64-bit system. I'm dubious about ROCK's attempts to
automatically add dual-licensing to all their patches, but bin86 is
already GPL'd. I've heard from the maintainer that this will be
included in the next upload.
# --- ROCK-COPYRIGHT-NOTE-BEGIN ---
#
# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
# Please add additional copyright information _after_ the line containing
# the ROCK-COPYRIGHT-NOTE-END tag. Otherwise it might get removed by
# the ./scripts/Create-CopyPatch script. Do not edit this copyright text!
#
# ROCK Linux: rock-src/package/x86/bin86/x86_64.patch
# ROCK Linux is Copyright (C) 1998 - 2005 Clifford Wolf
#
# This patch file is dual-licensed. It is available under the license the
# patched project is licensed under, as long as it is an OpenSource license
# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
# of the GNU General Public License as published by the Free Software
# Foundation; either version 2 of the License, or (at your option) any later
# version.
#
# --- ROCK-COPYRIGHT-NOTE-END ---
diff -urN bin86-0.16.14-orig/ld/x86_aout.h bin86-0.16.14/ld/x86_aout.h
--- bin86-0.16.14-orig/ld/x86_aout.h 2004-11-07 20:07:31.506442000 +0100
+++ bin86-0.16.14/ld/x86_aout.h 2004-11-07 20:07:41.106982496 +0100
@@ -12,6 +12,9 @@
#if defined(i386) || defined(__BCC__) || defined(MSDOS)
typedef long Long;
#define __OUT_OK 1
+#elif defined(__x86_64__)
+typedef int Long;
+#define __OUT_OK 1
#else
typedef char Long[4];
#endif

View file

@ -1,21 +1,22 @@
# $Id: PKGBUILD 46687 2009-07-19 16:41:59Z kevin $
# Maintainer: kevin <kevin@archlinux.org>
# Contributor: mario <mario_vazq@hotmail.com>
pkgname=dnsutils
# Use a period and not a hyphen before the patch level for proper versioning.
pkgver=9.6.1
_pkgver=9.6.1
pkgrel=2
pkgdesc="Various DNS utilities - dig host nslookup nsupdate"
arch=(i686 x86_64)
arch=('arm')
url="https://www.isc.org/software/bind"
license=('custom:ISC')
depends=('openssl>=0.9.8h')
replaces=('bind-tools' 'host')
options=('makeflags')
source=(http://ftp.isc.org/isc/bind9/${_pkgver}/bind-${_pkgver}.tar.gz
bind.so_bsdcompat.diff tools-only.patch)
md5sums=('516ac74d8eaaef30ad4c99ada8b715cd' '447d58721cfee0e1e377b46f7d50b327'
bind.so_bsdcompat.diff
tools-only.patch)
md5sums=('516ac74d8eaaef30ad4c99ada8b715cd'
'447d58721cfee0e1e377b46f7d50b327'
'329f7e15b8c45d3efefdf5b559bb878a')
build() {

View file

@ -1,10 +1,10 @@
# $Id: PKGBUILD 37639 2009-05-03 15:42:28Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
pkgname=jfsutils
pkgver=1.1.14
pkgrel=1
pkgdesc="JFS filesystem utilities"
arch=(i686 x86_64)
arch=('arm')
url="http://jfs.sourceforge.net"
license=('GPL')
groups=('base')
@ -19,4 +19,3 @@ build() {
make DESTDIR=$startdir/pkg install
mv $startdir/pkg/usr/sbin $startdir/pkg
}

View file

@ -1,35 +0,0 @@
2008-08-02 Eric Belanger <eric@archlinux.org>
* links 2.2-1
* Upstream update
2008-07-06 Eric Belanger <eric@archlinux.org>
* links 2.1-1
* Upstream update
2008-06-22 Eric Belanger <eric@archlinux.org>
* links 2.1pre37-1
* Upstream update
2008-06-01 Eric Belanger <eric@archlinux.org>
* links 2.1pre36-2
* Rebuilt against gpm 1.20.4
2008-05-13 Eric Belanger <eric@archlinux.org>
* links 2.1pre36-1
* Upstream update
2008-05-05 Eric Belanger <eric@archlinux.org>
* links 2.1pre35-1
* Upstream update
2008-05-04 Eric Belanger <eric@archlinux.org>
* links 2.1pre34-1
* Upstream update
* Added ChangeLog

View file

@ -1,4 +1,3 @@
# $Id: PKGBUILD 9076 2008-08-17 03:25:54Z allan $
# Maintainer: Eric Belanger <eric@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
@ -6,14 +5,13 @@ pkgname=links
pkgver=2.2
pkgrel=2
pkgdesc="A text WWW browser, similar to Lynx"
arch=('i686' 'x86_64')
arch=('arm')
url="http://atrey.karlin.mff.cuni.cz/~clock/twibright/links/"
license=('GPL')
depends=('bzip2' 'zlib' 'openssl' 'gpm>=1.20.4')
makedepends=('pkgconfig')
source=(http://links.twibright.com/download/${pkgname}-${pkgver}.tar.bz2)
md5sums=('bf5b20529a2a811701c5af52b28ebdd4')
sha1sums=('7588c151e98057f83a2e0b81b3f467e7eee9f824')
build() {
cd ${srcdir}/${pkgname}-${pkgver}