mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
removed community/coin-or-clp
This commit is contained in:
parent
91a506d8a8
commit
1b9b2c9ca2
2 changed files with 0 additions and 99 deletions
|
@ -1,51 +0,0 @@
|
||||||
From 472517388e866758b74821d4fa3945cf7da4b838 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
Date: Mon, 17 Jun 2019 17:41:11 -0600
|
|
||||||
Subject: [PATCH] Remove MMX and NEON headers
|
|
||||||
|
|
||||||
---
|
|
||||||
Clp/src/ClpPackedMatrix.cpp | 8 --------
|
|
||||||
Clp/src/ClpSimplexDual.cpp | 8 --------
|
|
||||||
2 files changed, 16 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Clp/src/ClpPackedMatrix.cpp b/Clp/src/ClpPackedMatrix.cpp
|
|
||||||
index ed26ff7..df2be84 100644
|
|
||||||
--- a/Clp/src/ClpPackedMatrix.cpp
|
|
||||||
+++ b/Clp/src/ClpPackedMatrix.cpp
|
|
||||||
@@ -6747,14 +6747,6 @@ ClpPackedMatrix3::ClpPackedMatrix3()
|
|
||||||
, ifActive_(0)
|
|
||||||
{
|
|
||||||
}
|
|
||||||
-#ifdef _MSC_VER
|
|
||||||
-#include <intrin.h>
|
|
||||||
-#elif defined(__arm__)
|
|
||||||
-#include <arm_neon.h>
|
|
||||||
-#else
|
|
||||||
-#include <immintrin.h>
|
|
||||||
-//#include <fmaintrin.h>
|
|
||||||
-#endif
|
|
||||||
/* Constructor from copy. */
|
|
||||||
ClpPackedMatrix3::ClpPackedMatrix3(ClpSimplex *model, const CoinPackedMatrix *columnCopy)
|
|
||||||
: numberBlocks_(0)
|
|
||||||
diff --git a/Clp/src/ClpSimplexDual.cpp b/Clp/src/ClpSimplexDual.cpp
|
|
||||||
index b5de7cc..ce46064 100644
|
|
||||||
--- a/Clp/src/ClpSimplexDual.cpp
|
|
||||||
+++ b/Clp/src/ClpSimplexDual.cpp
|
|
||||||
@@ -3554,14 +3554,6 @@ void moveAndZero(clpTempInfo *info, int type, void *extra)
|
|
||||||
}
|
|
||||||
}
|
|
||||||
#endif
|
|
||||||
-#ifdef _MSC_VER
|
|
||||||
-#include <intrin.h>
|
|
||||||
-#elif defined(__arm__)
|
|
||||||
-#include <arm_neon.h>
|
|
||||||
-#else
|
|
||||||
-#include <immintrin.h>
|
|
||||||
-//#include <fmaintrin.h>
|
|
||||||
-#endif
|
|
||||||
int ClpSimplexDual::dualColumn0(const CoinIndexedVector *rowArray,
|
|
||||||
const CoinIndexedVector *columnArray,
|
|
||||||
CoinIndexedVector *spareArray,
|
|
||||||
--
|
|
||||||
2.21.0
|
|
||||||
|
|
|
@ -1,48 +0,0 @@
|
||||||
# Maintainer: Antonio Rojas <arojas@archlinux.org>
|
|
||||||
# Contributor: spider-mario <spidermario@free.fr>
|
|
||||||
# Contributor: Daniel Ehlers <danielehlers@mindeye.net>
|
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
# - patch to remove MMX and NEON headers
|
|
||||||
|
|
||||||
pkgname=coin-or-clp
|
|
||||||
pkgver=1.17.3
|
|
||||||
pkgrel=1
|
|
||||||
pkgdesc="COIN-OR linear programming solver"
|
|
||||||
arch=(x86_64)
|
|
||||||
url="https://projects.coin-or.org/Clp"
|
|
||||||
license=(EPL)
|
|
||||||
groups=(coin-or)
|
|
||||||
depends=(coin-or-osi suitesparse)
|
|
||||||
source=("https://www.coin-or.org/download/source/Clp/Clp-${pkgver}.tgz"
|
|
||||||
0001-Remove-MMX-and-NEON-headers.patch)
|
|
||||||
sha256sums=('a13bf54291ad503cf76f5f93f2643d2add4faa5d0e60ff2db902ef715c094573'
|
|
||||||
'0d778e38571919a804a0c98e8182b768f7d069f39cf01cc22f551d0ff18317c1')
|
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd Clp-$pkgver/Clp
|
|
||||||
patch -p2 -i $srcdir/0001-Remove-MMX-and-NEON-headers.patch
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
|
||||||
cd Clp-$pkgver/Clp
|
|
||||||
COIN_SKIP_PROJECTS="Sample" \
|
|
||||||
./configure --prefix=/usr \
|
|
||||||
--with-osi-lib="$(pkg-config --libs osi)" \
|
|
||||||
--with-osi-incdir="/usr/include/coin/" \
|
|
||||||
--with-coinutils-lib="$(pkg-config --libs coinutils)" \
|
|
||||||
--with-coinutils-incdir="/usr/include/coin/" \
|
|
||||||
--with-cholmod-lib='-lcholmod' --with-cholmod-incdir=/usr/include
|
|
||||||
make
|
|
||||||
}
|
|
||||||
|
|
||||||
check() {
|
|
||||||
cd Clp-$pkgver/Clp
|
|
||||||
# make test
|
|
||||||
}
|
|
||||||
|
|
||||||
package() {
|
|
||||||
cd Clp-$pkgver/Clp
|
|
||||||
PKG_CONFIG_LIBDIR="$pkgdir"/usr/lib/pkgconfig/ \
|
|
||||||
make DESTDIR="$pkgdir" install
|
|
||||||
}
|
|
Loading…
Reference in a new issue