mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added extra/webrtc-audio-processing
This commit is contained in:
parent
1c1b3b5000
commit
1cbb853302
2 changed files with 62 additions and 0 deletions
38
extra/webrtc-audio-processing/PKGBUILD
Normal file
38
extra/webrtc-audio-processing/PKGBUILD
Normal file
|
@ -0,0 +1,38 @@
|
|||
# $Id$
|
||||
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix AArch64 build
|
||||
|
||||
pkgname=webrtc-audio-processing
|
||||
pkgver=0.1
|
||||
pkgrel=2
|
||||
_gitrev=9413986
|
||||
pkgdesc="AudioProcessing library based on Google's implementation of WebRTC"
|
||||
arch=(i686 x86_64)
|
||||
url="http://freedesktop.org/software/pulseaudio/webrtc-audio-processing"
|
||||
license=(custom)
|
||||
depends=(gcc-libs)
|
||||
source=("$url/$pkgname-$pkgver.tar.xz"
|
||||
'webrtc-fix-typedefs-on-other-arches.patch')
|
||||
sha256sums=('ed4b52f9c2688b97628035a5565377d74704d7c04de4254a768df3342c7afedc'
|
||||
'883d37c252ea5875af2ddfe1dd5a56aee07c4517f5dfac34253d70b508cd1976')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
patch -p1 -i ../webrtc-fix-typedefs-on-other-arches.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
./configure --prefix=/usr --disable-static
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
make DESTDIR="$pkgdir" install
|
||||
|
||||
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
|
||||
install -Dm644 PATENTS "$pkgdir/usr/share/licenses/$pkgname/PATENTS"
|
||||
}
|
|
@ -0,0 +1,24 @@
|
|||
diff -Nur webrtc-audio-processing-0.1/src/typedefs.h webrtc-audio-processing-0.1.new/src/typedefs.h
|
||||
--- webrtc-audio-processing-0.1/src/typedefs.h 2011-10-21 00:29:33.000000000 -0400
|
||||
+++ webrtc-audio-processing-0.1.new/src/typedefs.h 2014-01-28 18:42:57.816865572 -0500
|
||||
@@ -77,7 +77,19 @@
|
||||
#define WEBRTC_ARCH_32_BITS
|
||||
#define WEBRTC_ARCH_LITTLE_ENDIAN
|
||||
#else
|
||||
-#error Please add support for your architecture in typedefs.h
|
||||
+/* instead of failing, use typical unix defines... */
|
||||
+#if __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
|
||||
+#define WEBRTC_ARCH_LITTLE_ENDIAN
|
||||
+#elif __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
|
||||
+#define WEBRTC_ARCH_BIG_ENDIAN
|
||||
+#else
|
||||
+#error __BYTE_ORDER__ isn't defined!
|
||||
+#endif
|
||||
+#if defined(__LP64__)
|
||||
+#define WEBRTC_ARCH_64_BITS
|
||||
+#else
|
||||
+#define WEBRTC_ARCH_32_BITS
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
#if defined(__SSE2__) || defined(_MSC_VER)
|
Loading…
Reference in a new issue