extra/webkit2gtk: fix

This commit is contained in:
Kevin Mihelich 2018-03-25 04:11:23 +00:00
parent e4d6da6f9c
commit 1e45991515
2 changed files with 16 additions and 5 deletions

View file

@ -25,7 +25,7 @@ source=(https://webkitgtk.org/releases/webkitgtk-${pkgver}.tar.xz{,.asc}
remove_atomics.patch)
sha256sums=('57f640f720bd9a8a7207f3321cf803a15c2f207b4e7b75ff1be17bc1eeb00a3c'
'SKIP'
'410449817b1b181737538be10d96d6d8aec134285f6288e80c96fbfdd5d19519')
'd0a1469fdaa5d6f4ff7e498d26470224916b64a6dbe28ba7ad699c19da9ee9ab')
validpgpkeys=('D7FCF61CF9A2DEAB31D81BD3F3D322D0EC4582C3')
prepare() {

View file

@ -1,10 +1,21 @@
--- Source/WTF/wtf/CMakeLists.txt.orig 2017-04-25 18:40:09.388755957 -0600
+++ Source/WTF/wtf/CMakeLists.txt 2017-04-25 18:40:15.478780549 -0600
@@ -182,7 +182,6 @@
--- Source/WTF/wtf/CMakeLists.txt.orig 2018-02-19 02:36:10.000000000 -0700
+++ Source/WTF/wtf/CMakeLists.txt 2018-03-24 21:42:12.759186320 -0600
@@ -315,7 +315,6 @@
set(WTF_SOURCES
Assertions.cpp
- Atomics.cpp
AutomaticThread.cpp
BitVector.cpp
ClockType.cpp
CPUTime.cpp
--- Source/JavaScriptCore/CMakeLists.txt.orig 2018-03-24 21:36:40.067891066 -0600
+++ Source/JavaScriptCore/CMakeLists.txt 2018-03-24 21:38:06.715707122 -0600
@@ -120,7 +120,7 @@
# __atomic_fetch_add_8 is not available as a compiler intrinsic. It is
# available on other platforms (including 32-bit Arm), so the link with
# libatomic is only neede on MIPS.
-if (WTF_CPU_MIPS)
+if (WTF_CPU_MIPS OR WTF_CPU_ARM)
list(APPEND JavaScriptCore_LIBRARIES
-latomic
)