mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/rust to 1.69.0-2
This commit is contained in:
parent
1f36a3b073
commit
1f6038194f
4 changed files with 28 additions and 27 deletions
|
@ -9,19 +9,19 @@ Subject: [PATCH] bootstrap: Change libexec dir
|
|||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
||||
index 6594b23c56b0..2e6a96ba4d79 100644
|
||||
index 9b2b549612d8..80bb25199dcb 100644
|
||||
--- a/src/bootstrap/dist.rs
|
||||
+++ b/src/bootstrap/dist.rs
|
||||
@@ -404,7 +404,7 @@ fn prepare_image(builder: &Builder<'_>, compiler: Compiler, image: &Path) {
|
||||
target: compiler.host,
|
||||
})
|
||||
.expect("rust-analyzer-proc-macro-server always builds");
|
||||
- builder.install(&ra_proc_macro_srv, &image.join("libexec"), 0o755);
|
||||
+ builder.install(&ra_proc_macro_srv, &image.join("lib"), 0o755);
|
||||
@@ -414,7 +414,7 @@ fn prepare_image(builder: &Builder<'_>, compiler: Compiler, image: &Path) {
|
||||
},
|
||||
builder.kind,
|
||||
) {
|
||||
- builder.install(&ra_proc_macro_srv, &image.join("libexec"), 0o755);
|
||||
+ builder.install(&ra_proc_macro_srv, &image.join("lib"), 0o755);
|
||||
}
|
||||
|
||||
let libdir_relative = builder.libdir_relative(compiler);
|
||||
|
||||
@@ -1047,7 +1047,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
||||
@@ -1064,7 +1064,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
||||
for dirent in fs::read_dir(cargo.parent().unwrap()).expect("read_dir") {
|
||||
let dirent = dirent.expect("read dir entry");
|
||||
if dirent.file_name().to_str().expect("utf8").starts_with("cargo-credential-") {
|
||||
|
@ -31,10 +31,10 @@ index 6594b23c56b0..2e6a96ba4d79 100644
|
|||
}
|
||||
|
||||
diff --git a/src/bootstrap/tool.rs b/src/bootstrap/tool.rs
|
||||
index 9a2100c2fb78..d51b1ff8449e 100644
|
||||
index 3c9a154da9ab..3f57819fd96d 100644
|
||||
--- a/src/bootstrap/tool.rs
|
||||
+++ b/src/bootstrap/tool.rs
|
||||
@@ -792,7 +792,7 @@ fn run(self, builder: &Builder<'_>) -> Option<PathBuf> {
|
||||
@@ -850,7 +850,7 @@ fn run(self, builder: &Builder<'_>) -> Option<PathBuf> {
|
||||
|
||||
// Copy `rust-analyzer-proc-macro-srv` to `<sysroot>/libexec/`
|
||||
// so that r-a can use it.
|
||||
|
|
|
@ -8,10 +8,10 @@ Subject: [PATCH] cargo: Change libexec dir
|
|||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/cargo/util/auth.rs b/src/cargo/util/auth.rs
|
||||
index 467abc2635a0..30232251b3a2 100644
|
||||
index f7d0fc8c4a26..d296da754218 100644
|
||||
--- a/src/cargo/util/auth.rs
|
||||
+++ b/src/cargo/util/auth.rs
|
||||
@@ -817,7 +817,7 @@ fn sysroot_credential(
|
||||
@@ -816,7 +816,7 @@ fn sysroot_credential(
|
||||
.parent()
|
||||
.and_then(|p| p.parent())
|
||||
.ok_or_else(|| format_err!("expected cargo path {}", cargo.display()))?;
|
||||
|
|
|
@ -24,10 +24,10 @@ targets, as things break when this is done:
|
|||
4 files changed, 12 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
|
||||
index 586454f76574..b831e9c4e18f 100644
|
||||
index d4e4ace889b0..f653be447ab1 100644
|
||||
--- a/compiler/rustc_session/src/config.rs
|
||||
+++ b/compiler/rustc_session/src/config.rs
|
||||
@@ -1887,7 +1887,7 @@ pub fn parse_target_triple(
|
||||
@@ -1930,7 +1930,7 @@ pub fn parse_target_triple(
|
||||
early_error(error_format, &format!("target file {path:?} does not exist"))
|
||||
})
|
||||
}
|
||||
|
@ -50,10 +50,10 @@ index 73e536a7e4d9..af48d437533c 100644
|
|||
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
|
||||
f64:32:64-f80:32-n8:16:32-S128"
|
||||
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
||||
index a094c2c54526..610241905ea8 100644
|
||||
index 0d86a3032a65..b663a6d4ddb1 100644
|
||||
--- a/compiler/rustc_target/src/spec/mod.rs
|
||||
+++ b/compiler/rustc_target/src/spec/mod.rs
|
||||
@@ -2952,6 +2952,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||
@@ -2964,6 +2964,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||
Ok(TargetTriple::TargetJson { path_for_rustdoc: canonicalized_path, triple, contents })
|
||||
}
|
||||
|
||||
|
@ -70,11 +70,11 @@ index a094c2c54526..610241905ea8 100644
|
|||
///
|
||||
/// If this target is a path, the file name (without extension) is returned.
|
||||
diff --git a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
index a91ab365b668..d605eb9ccf81 100644
|
||||
index 9af1049b8702..f2ca57a00e3d 100644
|
||||
--- a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
+++ b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
|
||||
@@ -14,7 +14,7 @@ pub fn target() -> Target {
|
||||
| SanitizerSet::THREAD;
|
||||
@@ -15,7 +15,7 @@ pub fn target() -> Target {
|
||||
base.supports_xray = true;
|
||||
|
||||
Target {
|
||||
- llvm_target: "x86_64-unknown-linux-gnu".into(),
|
||||
|
|
|
@ -20,8 +20,8 @@ pkgname=(
|
|||
rust-src
|
||||
)
|
||||
epoch=1
|
||||
pkgver=1.68.2
|
||||
pkgrel=1
|
||||
pkgver=1.69.0
|
||||
pkgrel=2
|
||||
pkgdesc="Systems programming language focused on safety, speed and concurrency"
|
||||
url=https://www.rust-lang.org/
|
||||
arch=(x86_64)
|
||||
|
@ -61,11 +61,11 @@ source=(
|
|||
0002-compiler-Change-LLVM-targets.patch
|
||||
0003-compiler-Use-wasm-ld-for-wasm-targets.patch
|
||||
)
|
||||
b2sums=('acc31c33a4b9ed7af2866007b995a8be074fc87d31ee20540b4caa926277e5f7982c8cecd16f25d6e4fa4986f1181a30f5c0260ec6b9cf6260c742b2a94c1581'
|
||||
b2sums=('1440ad3e7e52d1e31752c8a44f9e626b9c2b0388f7285ddbdf1d0f7802724e707daffe19c6ba4aec62c3dba0e60ec2426ebecf69268b1e20a0c89860964a64f3'
|
||||
'SKIP'
|
||||
'dce1c2340b172753b9d56dcc9d401e4cd9c66d64721c97e256974c18f17b0489e65e3732ef4e15538ea6e07c34f1269775a51c0c7c72e63a62f41ff258ce9ec2'
|
||||
'01dee52ef899c0545cde37b5e1ba3ecfd5def3785145ed9f440df12945885311b63ff974294c1efed65b25b01bdb5cea37d7830e8d9775daefec8c1bcd3e159b'
|
||||
'66c5cf262c4b865cdcc238d88aad4aa46e0861de0b4e20b5e86f7f1c312f7a40df0f9477fbc494949a99f51e9eb93537c072270e9bd20dfa79eb5cbe0d850e0f'
|
||||
'd1a029499dd221b24124b193f7d42e9cb766d4bb9c4faa61a4b60007550693c98f1d1ab6793dd16b9f5a229bc70f805d6cd5eca6e744b34c0fd2413701bc58b6'
|
||||
'9752dc3b5fc2248c8bec4efbb3d927088d48d9416229d545a05180374549a0dda6e9d6d9a8d0a3b03437f2e3c54f9c153aab3281d46411f4c81559033b8fb04a'
|
||||
'a92b1eb9bc4101e055f89d9810c99e6e6472b3bb27bb01f8ea8a4b35f7e25512858e1555c2807eb7e8175df22c2e7937753d6787013920f9c76587e71f8df2f4'
|
||||
'9f3f911088a22101f8966dc16a1ecc65da5facaad5c169d9464e721aa452dd45968d359a5b35ae74ff23bd98d44c60cb04c0b8bc89e10fb99549c1670371c902')
|
||||
validpgpkeys=(108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
||||
474E22316ABF4785A88C6E8EA2C794A986419D8A) # Tom Stellard <tstellar@redhat.com>
|
||||
|
@ -99,9 +99,10 @@ locked-deps = true
|
|||
vendor = true
|
||||
tools = [
|
||||
"cargo",
|
||||
"rls",
|
||||
"clippy",
|
||||
"rustdoc",
|
||||
"rustfmt",
|
||||
#"rust-analyzer", # built separately
|
||||
"analysis",
|
||||
"src",
|
||||
"rust-demangler",
|
||||
|
|
Loading…
Reference in a new issue