mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
core/linux-armv7-rc to 4.0.rc4-2
This commit is contained in:
parent
daaf5fa82a
commit
1f8ad20687
9 changed files with 316 additions and 32 deletions
|
@ -1,7 +1,7 @@
|
|||
From 7ba704a48c49367dda65d1297a4c06a1eb4e8c9c Mon Sep 17 00:00:00 2001
|
||||
From 8d8a53924116b52b48f3aa0dfcc73f005591636a Mon Sep 17 00:00:00 2001
|
||||
From: Willy Tarreau <w@xxxxxx>
|
||||
Date: Sun, 2 Dec 2012 19:59:28 +0100
|
||||
Subject: [PATCH 1/5] ARM: atags: add support for Marvell's u-boot
|
||||
Subject: [PATCH 1/7] ARM: atags: add support for Marvell's u-boot
|
||||
|
||||
Marvell uses a specific atag in its u-boot which includes among other
|
||||
information the MAC addresses for up to 4 network interfaces.
|
||||
|
@ -47,5 +47,5 @@ index 979ff40..d1d0c19 100644
|
|||
};
|
||||
|
||||
--
|
||||
2.3.0
|
||||
2.3.3
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From efad5852f3be8cc444662c3a1ecf22edd38427d4 Mon Sep 17 00:00:00 2001
|
||||
From 6bf1b98d30782f2151c6a3a7e78ea6e3729e0c11 Mon Sep 17 00:00:00 2001
|
||||
From: Willy Tarreau <w@xxxxxx>
|
||||
Date: Sun, 2 Dec 2012 19:56:58 +0100
|
||||
Subject: [PATCH 2/5] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
|
||||
Subject: [PATCH 2/7] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
|
||||
loader
|
||||
|
||||
The atags are parsed and if a Marvell atag is found, up to 4 MAC
|
||||
|
@ -43,5 +43,5 @@ index 9448aa0..ac7b6ae 100644
|
|||
}
|
||||
|
||||
--
|
||||
2.3.0
|
||||
2.3.3
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 9a1d31f61b309e8a4ebc6a4c85154f20b94af3e2 Mon Sep 17 00:00:00 2001
|
||||
From 790d387080a8caffbbc6cc17bba91c278a1e120c Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 5 Sep 2014 15:41:19 -0600
|
||||
Subject: [PATCH 3/5] SMILE Plug device tree file
|
||||
Subject: [PATCH 3/7] SMILE Plug device tree file
|
||||
|
||||
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
|
||||
dts with the LED definitions.
|
||||
|
@ -14,10 +14,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
create mode 100644 arch/arm/boot/dts/armada-370-smileplug.dts
|
||||
|
||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index 91bd5bd..22618d7 100644
|
||||
index a1c776b..6ab2088 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -527,6 +527,7 @@ dtb-$(CONFIG_ARCH_ZYNQ) += \
|
||||
@@ -613,6 +613,7 @@ dtb-$(CONFIG_ARCH_ZYNQ) += \
|
||||
dtb-$(CONFIG_MACH_ARMADA_370) += \
|
||||
armada-370-db.dtb \
|
||||
armada-370-mirabox.dtb \
|
||||
|
@ -205,5 +205,5 @@ index 0000000..d01308a
|
|||
+ };
|
||||
+};
|
||||
--
|
||||
2.3.0
|
||||
2.3.3
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 29195baa48fe67ae6c0731edc5c64dee9aaf4851 Mon Sep 17 00:00:00 2001
|
||||
From 6af65049662258b9922f57fdd7c9f47e54e6e979 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 5 Sep 2014 15:43:56 -0600
|
||||
Subject: [PATCH 4/5] fix mvsdio eMMC timing
|
||||
Subject: [PATCH 4/7] fix mvsdio eMMC timing
|
||||
|
||||
These changes from Globalscale change the MMC timing to allow the eMMC versions
|
||||
of the Mirabox and SMILE Plug to work.
|
||||
|
@ -12,10 +12,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
|
||||
index 4f8618f..ab95bb7 100644
|
||||
index a448498..14441a6 100644
|
||||
--- a/drivers/mmc/host/mvsdio.c
|
||||
+++ b/drivers/mmc/host/mvsdio.c
|
||||
@@ -97,7 +97,7 @@ static int mvsd_setup_data(struct mvsd_host *host, struct mmc_data *data)
|
||||
@@ -96,7 +96,7 @@ static int mvsd_setup_data(struct mvsd_host *host, struct mmc_data *data)
|
||||
tmout_index = fls(tmout - 1) - 12;
|
||||
if (tmout_index < 0)
|
||||
tmout_index = 0;
|
||||
|
@ -24,7 +24,7 @@ index 4f8618f..ab95bb7 100644
|
|||
tmout_index = MVSD_HOST_CTRL_TMOUT_MAX;
|
||||
|
||||
dev_dbg(host->dev, "data %s at 0x%08x: blocks=%d blksz=%d tmout=%u (%d)\n",
|
||||
@@ -619,6 +619,8 @@ static void mvsd_set_ios(struct mmc_host *mmc, struct mmc_ios *ios)
|
||||
@@ -618,6 +618,8 @@ static void mvsd_set_ios(struct mmc_host *mmc, struct mmc_ios *ios)
|
||||
u32 m = DIV_ROUND_UP(host->base_clock, ios->clock) - 1;
|
||||
if (m > MVSD_BASE_DIV_MAX)
|
||||
m = MVSD_BASE_DIV_MAX;
|
||||
|
@ -34,5 +34,5 @@ index 4f8618f..ab95bb7 100644
|
|||
host->clock = ios->clock;
|
||||
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
|
||||
--
|
||||
2.3.0
|
||||
2.3.3
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 5d0fb467e28aeff79590ddcbe69219f4fc2b8fdf Mon Sep 17 00:00:00 2001
|
||||
From 89f3f1b4b2fca499083e90ecfd99c2694791ad87 Mon Sep 17 00:00:00 2001
|
||||
From: popcornmix <popcornmix@gmail.com>
|
||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||
Subject: [PATCH 5/5] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
Subject: [PATCH 5/7] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
|
||||
---
|
||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||
|
@ -91,5 +91,5 @@ index 26423ad..e29a323 100644
|
|||
if (smsc95xx_read_eeprom(dev, EEPROM_MAC_OFFSET, ETH_ALEN,
|
||||
dev->net->dev_addr) == 0) {
|
||||
--
|
||||
2.3.0
|
||||
2.3.3
|
||||
|
||||
|
|
229
core/linux-armv7-rc/0006-USB-armory-support.patch
Normal file
229
core/linux-armv7-rc/0006-USB-armory-support.patch
Normal file
|
@ -0,0 +1,229 @@
|
|||
From 1433ac2c2e9670d77f0fb37a0e8116eb0131e061 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 7 Mar 2015 16:51:15 -0700
|
||||
Subject: [PATCH 6/7] USB armory support
|
||||
|
||||
---
|
||||
arch/arm/boot/dts/Makefile | 1 +
|
||||
arch/arm/boot/dts/imx53-usbarmory.dts | 197 ++++++++++++++++++++++++++++++++++
|
||||
2 files changed, 198 insertions(+)
|
||||
create mode 100644 arch/arm/boot/dts/imx53-usbarmory.dts
|
||||
|
||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index 6ab2088..dfaf137 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -244,6 +244,7 @@ dtb-$(CONFIG_SOC_IMX53) += \
|
||||
imx53-smd.dtb \
|
||||
imx53-tx53-x03x.dtb \
|
||||
imx53-tx53-x13x.dtb \
|
||||
+ imx53-usbarmory.dtb \
|
||||
imx53-voipac-bsb.dtb
|
||||
dtb-$(CONFIG_SOC_IMX6Q) += \
|
||||
imx6dl-aristainetos_4.dtb \
|
||||
diff --git a/arch/arm/boot/dts/imx53-usbarmory.dts b/arch/arm/boot/dts/imx53-usbarmory.dts
|
||||
new file mode 100644
|
||||
index 0000000..ff411be
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/imx53-usbarmory.dts
|
||||
@@ -0,0 +1,197 @@
|
||||
+/*
|
||||
+ * Copyright 2015 Inverse Path, S.r.l.
|
||||
+ *
|
||||
+ * The code contained herein is licensed under the GNU General Public
|
||||
+ * License. You may obtain a copy of the GNU General Public License
|
||||
+ * Version 2 or later at the following locations:
|
||||
+ *
|
||||
+ * http://www.opensource.org/licenses/gpl-license.html
|
||||
+ * http://www.gnu.org/copyleft/gpl.html
|
||||
+ */
|
||||
+
|
||||
+/dts-v1/;
|
||||
+#include "imx53.dtsi"
|
||||
+
|
||||
+/ {
|
||||
+ model = "Inverse Path USB armory";
|
||||
+ compatible = "inversepath,imx53-usbarmory", "fsl,imx53";
|
||||
+};
|
||||
+
|
||||
+/ {
|
||||
+ chosen {
|
||||
+ stdout-path = &uart1;
|
||||
+ };
|
||||
+
|
||||
+ memory {
|
||||
+ reg = <0x70000000 0x20000000>;
|
||||
+ };
|
||||
+
|
||||
+ leds {
|
||||
+ compatible = "gpio-leds";
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&led_pin_gpio4_27>;
|
||||
+
|
||||
+ user {
|
||||
+ label = "LED";
|
||||
+ gpios = <&gpio4 27 0>;
|
||||
+ linux,default-trigger = "heartbeat";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ soc {
|
||||
+ aips@60000000 {
|
||||
+ sahara: crypto@63ff8000 {
|
||||
+ compatible = "fsl,imx53-sahara";
|
||||
+ reg = <0x63ff8000 0x4000>;
|
||||
+ interrupts = <19 20>;
|
||||
+ clocks = <&clks IMX5_CLK_SAHARA_IPG_GATE>,
|
||||
+ <&clks IMX5_CLK_SAHARA_IPG_GATE>;
|
||||
+ clock-names = "ipg", "ahb";
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&esdhc1 {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&pinctrl_esdhc1>;
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&iomuxc {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&pinctrl_hog>;
|
||||
+
|
||||
+ imx53-usbarmory {
|
||||
+ pinctrl_hog: hoggrp {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_GPIO_0__CCM_SSI_EXT1_CLK 0x80000000
|
||||
+ MX53_PAD_GPIO_8__GPIO1_8 0x80000000
|
||||
+ MX53_PAD_PATA_DATA14__GPIO2_14 0x80000000
|
||||
+ MX53_PAD_PATA_DATA15__GPIO2_15 0x80000000
|
||||
+ MX53_PAD_EIM_DA11__GPIO3_11 0x80000000
|
||||
+ MX53_PAD_EIM_DA12__GPIO3_12 0x80000000
|
||||
+ MX53_PAD_PATA_DA_0__GPIO7_6 0x80000000
|
||||
+ MX53_PAD_PATA_DA_2__GPIO7_8 0x80000000
|
||||
+ MX53_PAD_GPIO_16__GPIO7_11 0x80000000
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ led_pin_gpio4_27: led_gpio4_27@0 {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_DISP0_DAT6__GPIO4_27 0x80000000
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ pinctrl_esdhc1: esdhc1grp {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_SD1_DATA0__ESDHC1_DAT0 0x1d5
|
||||
+ MX53_PAD_SD1_DATA1__ESDHC1_DAT1 0x1d5
|
||||
+ MX53_PAD_SD1_DATA2__ESDHC1_DAT2 0x1d5
|
||||
+ MX53_PAD_SD1_DATA3__ESDHC1_DAT3 0x1d5
|
||||
+ MX53_PAD_SD1_CMD__ESDHC1_CMD 0x1d5
|
||||
+ MX53_PAD_SD1_CLK__ESDHC1_CLK 0x1d5
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ pinctrl_i2c1: i2c1grp {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_CSI0_DAT8__I2C1_SDA 0xc0000000
|
||||
+ MX53_PAD_CSI0_DAT9__I2C1_SCL 0xc0000000
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ pinctrl_uart1: uart1grp {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_CSI0_DAT10__UART1_TXD_MUX 0x1e4
|
||||
+ MX53_PAD_CSI0_DAT11__UART1_RXD_MUX 0x1e4
|
||||
+ >;
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&uart1 {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&pinctrl_uart1>;
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&vpu {
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&usbotg {
|
||||
+ dr_mode = "peripheral";
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&i2c1 {
|
||||
+ ltc3589: pmic@34 {
|
||||
+ compatible = "lltc,ltc3589-2";
|
||||
+ reg = <0x34>;
|
||||
+
|
||||
+ regulators {
|
||||
+ sw1_reg: sw1 {
|
||||
+ regulator-min-microvolt = <591930>;
|
||||
+ regulator-max-microvolt = <1224671>;
|
||||
+ lltc,fb-voltage-divider = <100000 158000>;
|
||||
+ regulator-ramp-delay = <7000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ sw2_reg: sw2 {
|
||||
+ regulator-min-microvolt = <704123>;
|
||||
+ regulator-max-microvolt = <1456803>;
|
||||
+ lltc,fb-voltage-divider = <180000 191000>;
|
||||
+ regulator-ramp-delay = <7000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ sw3_reg: sw3 {
|
||||
+ regulator-min-microvolt = <1341250>;
|
||||
+ regulator-max-microvolt = <2775000>;
|
||||
+ lltc,fb-voltage-divider = <270000 100000>;
|
||||
+ regulator-ramp-delay = <7000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ bb_out_reg: bb-out {
|
||||
+ regulator-min-microvolt = <3387341>;
|
||||
+ regulator-max-microvolt = <3387341>;
|
||||
+ lltc,fb-voltage-divider = <511000 158000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+ ldo1_reg: ldo1 {
|
||||
+ regulator-min-microvolt = <1306329>;
|
||||
+ regulator-max-microvolt = <1306329>;
|
||||
+ lltc,fb-voltage-divider = <100000 158000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ ldo2_reg: ldo2 {
|
||||
+ regulator-min-microvolt = <704123>;
|
||||
+ regulator-max-microvolt = <1456806>;
|
||||
+ lltc,fb-voltage-divider = <180000 191000>;
|
||||
+ regulator-ramp-delay = <7000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ ldo3_reg: ldo3 {
|
||||
+ regulator-min-microvolt = <2800000>;
|
||||
+ regulator-max-microvolt = <2800000>;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ ldo4_reg: ldo4 {
|
||||
+ regulator-min-microvolt = <1200000>;
|
||||
+ regulator-max-microvolt = <3200000>;
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
--
|
||||
2.3.3
|
||||
|
|
@ -0,0 +1,49 @@
|
|||
From a29e28f0af5a6a664767aed00c9b607f25d01c89 Mon Sep 17 00:00:00 2001
|
||||
From: dobatog <dobatog@gmail.com>
|
||||
Date: Thu, 26 Feb 2015 12:32:27 +0100
|
||||
Subject: [PATCH 7/7] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
|
||||
related to input routing signals.
|
||||
|
||||
The following patch, based on stable v3.19, corrects the errors that are reported in the boot trace in reference to the Input Signals of the audio codec TLV320AIC23:
|
||||
|
||||
tlv320aic23-codec 1-001a: Control not supported for path LLINEIN -> [NULL] -> Line Input
|
||||
tlv320aic23-codec 1-001a: ASoC: no dapm match for LLINEIN --> NULL --> Line Input
|
||||
tlv320aic23-codec 1-001a: ASoC: Failed to add route LLINEIN -> NULL -> Line Input
|
||||
tlv320aic23-codec 1-001a: Control not supported for path RLINEIN -> [NULL] -> Line Input
|
||||
tlv320aic23-codec 1-001a: ASoC: no dapm match for RLINEIN --> NULL --> Line Input
|
||||
tlv320aic23-codec 1-001a: ASoC: Failed to add route RLINEIN -> NULL -> Line Input
|
||||
tlv320aic23-codec 1-001a: Control not supported for path MICIN -> [NULL] -> Mic Input
|
||||
tlv320aic23-codec 1-001a: ASoC: no dapm match for MICIN --> NULL --> Mic Input
|
||||
tlv320aic23-codec 1-001a: ASoC: Failed to add route MICIN -> NULL -> Mic Input
|
||||
|
||||
I am trying to set the sound system in a CM-510 (Compulab - SoM) based board with DT, using Simple-Card-Audio and the TLV320AIC23 audio codec included in the SoM . I faced this problem and thanks to the help of Sebastian Hesselbarth who noticed the possible error located in the structure snd_soc_dapm_route tlv320aic23_intercon[] , now errors are not reported.
|
||||
|
||||
Tested on CM-510 (Compulab SoM Board).
|
||||
|
||||
Signed-off-by: dobatog <dobatog@gmail.com>
|
||||
Tested-by: Max Filippov <jcmvbkbc@gmail.com>
|
||||
---
|
||||
sound/soc/codecs/tlv320aic23.c | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/sound/soc/codecs/tlv320aic23.c b/sound/soc/codecs/tlv320aic23.c
|
||||
index cc17e7e..891f3aa 100644
|
||||
--- a/sound/soc/codecs/tlv320aic23.c
|
||||
+++ b/sound/soc/codecs/tlv320aic23.c
|
||||
@@ -174,10 +174,10 @@ static const struct snd_soc_dapm_route tlv320aic23_intercon[] = {
|
||||
{"ROUT", NULL, "Output Mixer"},
|
||||
|
||||
/* Inputs */
|
||||
- {"Line Input", "NULL", "LLINEIN"},
|
||||
- {"Line Input", "NULL", "RLINEIN"},
|
||||
+ {"Line Input", NULL, "LLINEIN"},
|
||||
+ {"Line Input", NULL, "RLINEIN"},
|
||||
|
||||
- {"Mic Input", "NULL", "MICIN"},
|
||||
+ {"Mic Input", NULL, "MICIN"},
|
||||
|
||||
/* input mux */
|
||||
{"Capture Source", "Line", "Line Input"},
|
||||
--
|
||||
2.3.3
|
||||
|
|
@ -13,7 +13,7 @@ _srcname=linux-3.19
|
|||
_kernelname=${pkgbase#linux}
|
||||
_desc="ARMv7 multi-platform"
|
||||
pkgver=${_rcver}.rc${_rcrel}
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
arch=('armv7h')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
|
@ -28,17 +28,21 @@ source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
|
|||
'0003-SMILE-Plug-device-tree-file.patch'
|
||||
'0004-fix-mvsdio-eMMC-timing.patch'
|
||||
'0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
||||
'0006-USB-armory-support.patch'
|
||||
'0007-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch'
|
||||
'config')
|
||||
md5sums=('d3fc8316d4d4d04b65cbc2d70799e763'
|
||||
'5282c9ea279dc5fdf3865b001cc0d6a8'
|
||||
'd8d8f47b2f808e943ce9af688270dc4c'
|
||||
'SKIP'
|
||||
'98931609e0e5c0beb3dbaabfb669b872'
|
||||
'b7aa41223a0eff197ab905d9791e4ec4'
|
||||
'd71cd90ee737afc07708fae7e449d651'
|
||||
'950087add736d74afacd54bcfe8908d9'
|
||||
'd6ef79617d7e59e841f4f3d65501a6d8'
|
||||
'94ade3158dad220f93f8e7dc7c4ad580')
|
||||
'8ae47c547d49a906c4a5e856fb24bcb4'
|
||||
'931a9a9e35084effd875e4ad095329a6'
|
||||
'9878601068b4daaac9313d33d8cada3a'
|
||||
'3fa1e8e5789a00a402e997301be3da03'
|
||||
'cd6353fb52944f2adc4af0857c734abf'
|
||||
'c3dd1ee6c7fe9a3900b514641ecd6afa'
|
||||
'5a3decd0f8367c1b710fa6f93112c3e4'
|
||||
'cf469e596b5aef7347c539509bfca28c')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
@ -55,6 +59,8 @@ prepare() {
|
|||
git apply ../0003-SMILE-Plug-device-tree-file.patch
|
||||
git apply ../0004-fix-mvsdio-eMMC-timing.patch
|
||||
git apply ../0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
||||
git apply ../0006-USB-armory-support.patch
|
||||
git apply ../0007-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch
|
||||
|
||||
# AUFS patches
|
||||
#cp -ru "${srcdir}/aufs3-standalone/Documentation" .
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm 4.0.0-rc4-1 Kernel Configuration
|
||||
# Linux/arm 4.0.0-rc4-2 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM=y
|
||||
CONFIG_ARM_HAS_SG_CHAIN=y
|
||||
|
@ -1572,7 +1572,7 @@ CONFIG_NL80211_TESTMODE=y
|
|||
# CONFIG_CFG80211_CERTIFICATION_ONUS is not set
|
||||
CONFIG_CFG80211_DEFAULT_PS=y
|
||||
# CONFIG_CFG80211_DEBUGFS is not set
|
||||
CONFIG_CFG80211_INTERNAL_REGDB=y
|
||||
# CONFIG_CFG80211_INTERNAL_REGDB is not set
|
||||
# CONFIG_CFG80211_WEXT is not set
|
||||
CONFIG_LIB80211=m
|
||||
CONFIG_LIB80211_CRYPT_WEP=m
|
||||
|
@ -4010,7 +4010,7 @@ CONFIG_DVB_TTUSB_DEC=m
|
|||
CONFIG_SMS_USB_DRV=m
|
||||
CONFIG_DVB_B2C2_FLEXCOP_USB=m
|
||||
# CONFIG_DVB_B2C2_FLEXCOP_USB_DEBUG is not set
|
||||
# CONFIG_DVB_AS102 is not set
|
||||
CONFIG_DVB_AS102=m
|
||||
|
||||
#
|
||||
# Webcam, TV (analog/digital) USB devices
|
||||
|
@ -4272,7 +4272,7 @@ CONFIG_DVB_RTL2830=m
|
|||
CONFIG_DVB_RTL2832=m
|
||||
CONFIG_DVB_RTL2832_SDR=m
|
||||
CONFIG_DVB_SI2168=m
|
||||
# CONFIG_DVB_AS102_FE is not set
|
||||
CONFIG_DVB_AS102_FE=m
|
||||
|
||||
#
|
||||
# DVB-C (cable) frontends
|
||||
|
@ -5479,7 +5479,7 @@ CONFIG_RTC_DRV_S35390A=y
|
|||
CONFIG_RTC_DRV_FM3130=m
|
||||
CONFIG_RTC_DRV_RX8581=m
|
||||
CONFIG_RTC_DRV_RX8025=m
|
||||
CONFIG_RTC_DRV_EM3027=m
|
||||
CONFIG_RTC_DRV_EM3027=y
|
||||
CONFIG_RTC_DRV_RV3029C2=m
|
||||
CONFIG_RTC_DRV_S5M=y
|
||||
|
||||
|
|
Loading…
Reference in a new issue