Kernel 2.6.37-5 with split GoFlexNet patch because it didnt work

This commit is contained in:
Mike Staszel 2011-01-31 12:28:02 -06:00
parent c0402777a7
commit 1fef45aa28
3 changed files with 139 additions and 134 deletions

View file

@ -0,0 +1,125 @@
diff -urN a//arch/arm/mach-kirkwood/goflexnet-setup.c b//arch/arm/mach-kirkwood/goflexnet-setup.c
--- a//arch/arm/mach-kirkwood/goflexnet-setup.c 1969-12-31 17:00:00.000000000 -0700
+++ b//arch/arm/mach-kirkwood/goflexnet-setup.c 2010-12-18 00:50:13.369176001 -0700
@@ -0,0 +1,121 @@
+/*
+ * arch/arm/mach-kirkwood/goflexnet-setup.c
+ *
+ * Seagate Goflex Net Setup
+ *
+ * This file is licensed under the terms of the GNU General Public
+ * License version 2. This program is licensed "as is" without any
+ * warranty of any kind, whether express or implied.
+ */
+
+#include <linux/kernel.h>
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/ata_platform.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mv643xx_eth.h>
+#include <linux/gpio.h>
+#include <linux/leds.h>
+#include <asm/mach-types.h>
+#include <asm/mach/arch.h>
+#include <mach/kirkwood.h>
+#include "common.h"
+#include "mpp.h"
+
+static struct mtd_partition goflexnet_nand_parts[] = {
+ {
+ .name = "u-boot",
+ .offset = 0,
+ .size = SZ_1M
+ }, {
+ .name = "uImage",
+ .offset = MTDPART_OFS_NXTBLK,
+ .size = SZ_4M
+ }, {
+ .name = "pogoplug",
+ .offset = MTDPART_OFS_NXTBLK,
+ .size = SZ_32M
+ }, {
+ .name = "root",
+ .offset = MTDPART_OFS_NXTBLK,
+ .size = MTDPART_SIZ_FULL
+ },
+};
+
+static struct mv643xx_eth_platform_data goflexnet_ge00_data = {
+ .phy_addr = MV643XX_ETH_PHY_ADDR(0),
+};
+
+static struct mv_sata_platform_data goflexnet_sata_data = {
+ .n_ports = 2,
+};
+
+static struct gpio_led goflexnet_led_pins[] = {
+ {
+ .name = "status:green:health",
+ .default_trigger = "default-on",
+ .gpio = 46,
+ .active_low = 1,
+ },
+ {
+ .name = "status:orange:fault",
+ .default_trigger = "none",
+ .gpio = 47,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_led_platform_data goflexnet_led_data = {
+ .leds = goflexnet_led_pins,
+ .num_leds = ARRAY_SIZE(goflexnet_led_pins),
+};
+
+static struct platform_device goflexnet_leds = {
+ .name = "leds-gpio",
+ .id = -1,
+ .dev = {
+ .platform_data = &goflexnet_led_data,
+ }
+};
+
+static unsigned int goflexnet_mpp_config[] __initdata = {
+ MPP29_GPIO, /* USB Power Enable */
+ MPP47_GPIO, /* LED Orange */
+ MPP46_GPIO, /* LED Green */
+ 0
+};
+
+static void __init goflexnet_init(void)
+{
+ /*
+ * Basic setup. Needs to be called early.
+ */
+ kirkwood_init();
+
+ /* setup gpio pin select */
+ kirkwood_mpp_conf(goflexnet_mpp_config);
+
+ kirkwood_uart0_init();
+ kirkwood_nand_init(ARRAY_AND_SIZE(goflexnet_nand_parts), 25);
+
+ if (gpio_request(29, "USB Power Enable") != 0 ||
+ gpio_direction_output(29, 1) != 0)
+ printk(KERN_ERR "can't set up GPIO 29 (USB Power Enable)\n");
+ kirkwood_ehci_init();
+ kirkwood_ge00_init(&goflexnet_ge00_data);
+ kirkwood_sata_init(&goflexnet_sata_data);
+
+ platform_device_register(&goflexnet_leds);
+}
+
+MACHINE_START(GOFLEXNET, "Seagate Goflex Net")
+ /* Maintainer: Peter Carmichael <peterjncarm@ovi.com> */
+ .phys_io = KIRKWOOD_REGS_PHYS_BASE,
+ .io_pg_offst = ((KIRKWOOD_REGS_VIRT_BASE) >> 18) & 0xfffc,
+ .boot_params = 0x00000100,
+ .init_machine = goflexnet_init,
+ .map_io = kirkwood_map_io,
+ .init_irq = kirkwood_init_irq,
+ .timer = &kirkwood_timer,
+MACHINE_END
+

View file

@ -1,128 +1,3 @@
diff -urN a//arch/arm/mach-kirkwood/goflexnet-setup.c b//arch/arm/mach-kirkwood/goflexnet-setup.c
--- a//arch/arm/mach-kirkwood/goflexnet-setup.c 1969-12-31 17:00:00.000000000 -0700
+++ b//arch/arm/mach-kirkwood/goflexnet-setup.c 2010-12-18 00:50:13.369176001 -0700
@@ -0,0 +1,121 @@
+/*
+ * arch/arm/mach-kirkwood/goflexnet-setup.c
+ *
+ * Seagate Goflex Net Setup
+ *
+ * This file is licensed under the terms of the GNU General Public
+ * License version 2. This program is licensed "as is" without any
+ * warranty of any kind, whether express or implied.
+ */
+
+#include <linux/kernel.h>
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/ata_platform.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mv643xx_eth.h>
+#include <linux/gpio.h>
+#include <linux/leds.h>
+#include <asm/mach-types.h>
+#include <asm/mach/arch.h>
+#include <mach/kirkwood.h>
+#include "common.h"
+#include "mpp.h"
+
+static struct mtd_partition goflexnet_nand_parts[] = {
+ {
+ .name = "u-boot",
+ .offset = 0,
+ .size = SZ_1M
+ }, {
+ .name = "uImage",
+ .offset = MTDPART_OFS_NXTBLK,
+ .size = SZ_4M
+ }, {
+ .name = "pogoplug",
+ .offset = MTDPART_OFS_NXTBLK,
+ .size = SZ_32M
+ }, {
+ .name = "root",
+ .offset = MTDPART_OFS_NXTBLK,
+ .size = MTDPART_SIZ_FULL
+ },
+};
+
+static struct mv643xx_eth_platform_data goflexnet_ge00_data = {
+ .phy_addr = MV643XX_ETH_PHY_ADDR(0),
+};
+
+static struct mv_sata_platform_data goflexnet_sata_data = {
+ .n_ports = 2,
+};
+
+static struct gpio_led goflexnet_led_pins[] = {
+ {
+ .name = "status:green:health",
+ .default_trigger = "default-on",
+ .gpio = 46,
+ .active_low = 1,
+ },
+ {
+ .name = "status:orange:fault",
+ .default_trigger = "none",
+ .gpio = 47,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_led_platform_data goflexnet_led_data = {
+ .leds = goflexnet_led_pins,
+ .num_leds = ARRAY_SIZE(goflexnet_led_pins),
+};
+
+static struct platform_device goflexnet_leds = {
+ .name = "leds-gpio",
+ .id = -1,
+ .dev = {
+ .platform_data = &goflexnet_led_data,
+ }
+};
+
+static unsigned int goflexnet_mpp_config[] __initdata = {
+ MPP29_GPIO, /* USB Power Enable */
+ MPP47_GPIO, /* LED Orange */
+ MPP46_GPIO, /* LED Green */
+ 0
+};
+
+static void __init goflexnet_init(void)
+{
+ /*
+ * Basic setup. Needs to be called early.
+ */
+ kirkwood_init();
+
+ /* setup gpio pin select */
+ kirkwood_mpp_conf(goflexnet_mpp_config);
+
+ kirkwood_uart0_init();
+ kirkwood_nand_init(ARRAY_AND_SIZE(goflexnet_nand_parts), 25);
+
+ if (gpio_request(29, "USB Power Enable") != 0 ||
+ gpio_direction_output(29, 1) != 0)
+ printk(KERN_ERR "can't set up GPIO 29 (USB Power Enable)\n");
+ kirkwood_ehci_init();
+ kirkwood_ge00_init(&goflexnet_ge00_data);
+ kirkwood_sata_init(&goflexnet_sata_data);
+
+ platform_device_register(&goflexnet_leds);
+}
+
+MACHINE_START(GOFLEXNET, "Seagate Goflex Net")
+ /* Maintainer: Peter Carmichael <peterjncarm@ovi.com> */
+ .phys_io = KIRKWOOD_REGS_PHYS_BASE,
+ .io_pg_offst = ((KIRKWOOD_REGS_VIRT_BASE) >> 18) & 0xfffc,
+ .boot_params = 0x00000100,
+ .init_machine = goflexnet_init,
+ .map_io = kirkwood_map_io,
+ .init_irq = kirkwood_init_irq,
+ .timer = &kirkwood_timer,
+MACHINE_END
+
diff -urN a//arch/arm/mach-kirkwood/guruplug-setup.c b//arch/arm/mach-kirkwood/guruplug-setup.c
--- a//arch/arm/mach-kirkwood/guruplug-setup.c 2010-12-09 15:17:27.000000000 -0700
+++ b//arch/arm/mach-kirkwood/guruplug-setup.c 2010-12-18 00:50:13.409176002 -0700

View file

@ -3,6 +3,9 @@
noautobuild=1
# We split up the LED patch for the GoFlexNet because it was failing.
# This is hopefully temporary.
# In kernel26-headers, scsi.h is explicitly copied to the package
# this is done at the very end of this PKGBUILD
@ -11,10 +14,10 @@ pkgname=('kernel26' 'kernel26-headers')
_kernelname=${pkgname#kernel26}
_basekernel=2.6.37
pkgver=${_basekernel}
pkgrel=4
pkgrel=5
plugrel=1
makedepends=('xmlto' 'docbook-xsl' 'uboot-mkimage' 'make')
_patchname="patch-${pkgver}-${pkgrel}-ARCH"
_patchname="patch-${pkgver}-4-ARCH"
replaces=('kernel26-withlinux' 'kernel26-dockstar')
arch=(arm)
CARCH=arm
@ -30,12 +33,11 @@ source=(ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_basekernel.tar.bz2
md5sums=('c8ee37b4fdccdb651e0603d35350b434'
'732176aeb134678b4e369e1d5d5fca2e'
'f56257dbca522a0699cd5478224a6008'
'927bb9b3d5e48efa39740fdb1987799f'
'a6de179f742c92feaf24033569110182'
'25584700a0a679542929c4bed31433b6')
build() {
cd ${srcdir}/linux-$_basekernel
# Add -ARCH patches
# See http://projects.archlinux.org/linux-2.6-ARCH.git/
patch -Np1 -i ${srcdir}/${_patchname}
@ -50,12 +52,11 @@ build() {
# get kernel version
make prepare
# Configure the kernel. Replace the line below with one of your choice.
#make menuconfig # CLI menu for configuration
#make nconfig # new CLI menu for configuration
#make oldconfig # using old config from previous kernel version
yes "" | make config
# Build!
make ${MAKEFLAGS} uImage modules
}
@ -63,7 +64,7 @@ build() {
package_kernel26() {
pkgdesc="The Linux Kernel and modules"
groups=('base')
depends=('coreutils' 'module-init-tools')
depends=('coreutils' 'module-init-tools>=3.12-2')
replaces=('kernel24' 'kernel24-scsi' 'kernel26-scsi'
'alsa-driver' 'ieee80211' 'hostap-driver26'
'pwc' 'nforce' 'squashfs' 'unionfs' 'ivtv'
@ -71,8 +72,9 @@ package_kernel26() {
'gspcav1' 'atl2' 'wlan-ng26' 'rt2500' 'nouveau-drm'
'kernel26-withlinux' 'kernel26-dockstar')
install=kernel26.install
optdepends=('crda: to set the correct wireless channels of your country')
KARCH=arm
cd ${srcdir}/linux-$_basekernel
# get kernel version
_kernver="$(make kernelrelease)"
@ -89,6 +91,10 @@ package_kernel26() {
# remove build and source links
rm -f ${pkgdir}/lib/modules/${_kernver}/{source,build}
# remove the firmware
rm -rf ${pkgdir}/lib/firmware
# gzip -9 all modules to save 100MB of space
find "$pkgdir" -name '*.ko' -exec gzip -9 {} \;
}
package_kernel26-headers() {
@ -98,7 +104,6 @@ package_kernel26-headers() {
mkdir -p ${pkgdir}/lib/modules/${_kernver}
cd ${pkgdir}/lib/modules/${_kernver}
ln -sf ../../../usr/src/linux-${_kernver} build
cd ${srcdir}/linux-$_basekernel
install -D -m644 Makefile \
${pkgdir}/usr/src/linux-${_kernver}/Makefile