alarm/xf86-video-armsoc-meson to 0.5-4

This commit is contained in:
Kevin Mihelich 2018-06-28 00:20:26 +00:00
parent 3e400d4b46
commit 2280b12078
2 changed files with 45 additions and 2 deletions

View file

@ -0,0 +1,36 @@
From 05d4a444d7e05312cdb2f3c820db6fb7011bb3b7 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 14 Jun 2018 11:59:02 -0600
Subject: [PATCH] Initialize XRandR before EnterVT
---
src/armsoc_driver.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/armsoc_driver.c b/src/armsoc_driver.c
index b183788..1eb00f3 100644
--- a/src/armsoc_driver.c
+++ b/src/armsoc_driver.c
@@ -1093,6 +1093,9 @@ ARMSOCScreenInit(SCREEN_INIT_ARGS_DECL)
*/
pScrn->vtSema = TRUE;
+ /* Do some XRandR initialization. Return value is not useful */
+ (void)xf86CrtcScreenInit(pScreen);
+
/* Take over the virtual terminal from the console, set the
* desired mode, etc.:
*/
@@ -1103,9 +1106,6 @@ ARMSOCScreenInit(SCREEN_INIT_ARGS_DECL)
}
}
- /* Do some XRandR initialization. Return value is not useful */
- (void)xf86CrtcScreenInit(pScreen);
-
if (!miCreateDefColormap(pScreen)) {
ERROR_MSG("Cannot create colormap!");
goto fail7;
--
2.17.1

View file

@ -5,7 +5,7 @@ buildarch=8
pkgname=xf86-video-armsoc-meson pkgname=xf86-video-armsoc-meson
pkgver=0.5 pkgver=0.5
pkgrel=3 pkgrel=4
pkgdesc="X.org Mali video driver for Meson platforms" pkgdesc="X.org Mali video driver for Meson platforms"
arch=('aarch64') arch=('aarch64')
license=('MIT') license=('MIT')
@ -14,10 +14,17 @@ depends=('mali-utgard-meson-libgl-x11')
makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=24.0' 'git') makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=24.0' 'git')
conflicts=('xorg-server<1.20' 'X-ABI-VIDEODRV_VERSION<24' 'X-ABI-VIDEODRV_VERSION>=25') conflicts=('xorg-server<1.20' 'X-ABI-VIDEODRV_VERSION<24' 'X-ABI-VIDEODRV_VERSION>=25')
source=($pkgname::"git+${url}" source=($pkgname::"git+${url}"
0001-Initialize-XRandR-before-EnterVT.patch
99-mali-meson.conf) 99-mali-meson.conf)
sha256sums=('SKIP' sha256sums=('SKIP'
'a8abfb29efec9ba2c9a80a1c1fb68659c96b46b0b5a9a5f5cfbe691f0fdbf1fc'
'eca6ed5e20457d41a0fc9ac07034ee2682d5623cf6e566bf9df017d217540952') 'eca6ed5e20457d41a0fc9ac07034ee2682d5623cf6e566bf9df017d217540952')
prepare() {
cd $pkgname
git apply ../0001-Initialize-XRandR-before-EnterVT.patch
}
build() { build() {
cd $pkgname cd $pkgname