mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/libreoffice-fresh to 6.1.4-3
This commit is contained in:
parent
0111327004
commit
230ab2ac27
2 changed files with 94 additions and 1 deletions
|
@ -20,7 +20,7 @@ pkgbase=libreoffice-fresh
|
|||
pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
|
||||
_LOver=6.1.4.2
|
||||
pkgver=6.1.4
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
arch=('x86_64')
|
||||
license=('LGPL3')
|
||||
url="http://www.libreoffice.org/"
|
||||
|
@ -66,6 +66,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
|
|||
poppler-0.70.patch
|
||||
libreoffice-poppler-0.71.patch
|
||||
libreoffice-poppler-0.72.patch
|
||||
libreoffice-poppler-0.73.patch
|
||||
libreoffice-boost-1.69.patch
|
||||
0001-Update-mdds-to-1.4.1.patch
|
||||
0001-Update-orcus-to-0.14.0.patch
|
||||
|
@ -111,6 +112,7 @@ sha256sums=('648fe9177e0813625a99e775dac1354a416eef2f3ef44eab4e770d08293b37fe'
|
|||
'4cac21ffdb711803c0d5372c6b0ba04f1310afa7907081fdd01c11e68c1785bf'
|
||||
'ffe1698d3db3320a9213a459e7619f4962c9792a8b256ea0fe2b7e0af1df430a'
|
||||
'dc8b5b0d1a4a1fed4f5cab048cd7ecd78630725458311bcbfe0a660c82357b49'
|
||||
'69337273a8a125be1c9e066b955306659b19066c3c82b61c62bcb62234e2e1ad'
|
||||
'5099c5e7818a327b661c45c0bd218835c1e70b14861b5112525da1d48beebf8c'
|
||||
'8e8460302a7febc9a29b32b98fb77c85910ccadc65c73e0e9997dc5aabaaeb2a'
|
||||
'60560283a5e22acad7f341b16dff4a654559b36db5d49b1e59f3bb9ae9b2336c'
|
||||
|
@ -147,6 +149,8 @@ prepare() {
|
|||
patch -p1 -i ../libreoffice-poppler-0.71.patch
|
||||
# fix build with poppler 0.72
|
||||
patch -p1 -i ../libreoffice-poppler-0.72.patch
|
||||
# fix build with poppler 0.73
|
||||
patch -p1 -i ../libreoffice-poppler-0.73.patch
|
||||
# fix build with boost 1.69 (freebsd)
|
||||
patch -p0 -i ../libreoffice-boost-1.69.patch
|
||||
|
||||
|
|
89
extra/libreoffice-fresh/libreoffice-poppler-0.73.patch
Normal file
89
extra/libreoffice-fresh/libreoffice-poppler-0.73.patch
Normal file
|
@ -0,0 +1,89 @@
|
|||
From 50d371ae08c66648d9f32f633b2245e1746e2bb6 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Stahl <Michael.Stahl@cib.de>
|
||||
Date: Mon, 14 Jan 2019 15:08:42 +0100
|
||||
Subject: [PATCH] sdext: fix build with poppler 0.73
|
||||
|
||||
... which has removed Guchar, Gushort, Guint, Gulong...
|
||||
|
||||
Change-Id: Ia54ad378031f167f6779f6ffe574b85c1e72f26d
|
||||
Reviewed-on: https://gerrit.libreoffice.org/66305
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Michael Stahl <Michael.Stahl@cib.de>
|
||||
---
|
||||
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx | 4 ++--
|
||||
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 6 +++++-
|
||||
sdext/source/pdfimport/xpdfwrapper/pnghelper.cxx | 6 +++---
|
||||
3 files changed, 10 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
||||
index dab405bc81a1..9842b9734e8d 100644
|
||||
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
||||
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
||||
@@ -298,7 +298,7 @@ static void writePpm_( OutputBuffer& o_rOutputBuf,
|
||||
o_rOutputBuf.resize(header_size);
|
||||
|
||||
// initialize stream
|
||||
- Guchar *p;
|
||||
+ unsigned char *p;
|
||||
GfxRGB rgb;
|
||||
std::unique_ptr<ImageStream> imgStr(
|
||||
new ImageStream(str,
|
||||
@@ -401,7 +401,7 @@ static void writeImage_( OutputBuffer& o_rOutputBuf,
|
||||
oneColor = { byteToCol( 0xff ), byteToCol( 0xff ), byteToCol( 0xff ) };
|
||||
if( colorMap->getColorSpace()->getMode() == csIndexed || colorMap->getColorSpace()->getMode() == csDeviceGray )
|
||||
{
|
||||
- Guchar nIndex = 0;
|
||||
+ unsigned char nIndex = 0;
|
||||
colorMap->getRGB( &nIndex, &zeroColor );
|
||||
nIndex = 1;
|
||||
colorMap->getRGB( &nIndex, &oneColor );
|
||||
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
||||
index 98d8ede6418f..cd091e5d270f 100644
|
||||
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
||||
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
||||
@@ -278,9 +278,13 @@ extern FILE* g_binary_out;
|
||||
|
||||
// note: if you ever change Output_t, please keep in mind that the current code
|
||||
// relies on it being of 8 bit size
|
||||
-typedef Guchar Output_t;
|
||||
+typedef unsigned char Output_t;
|
||||
typedef std::vector< Output_t > OutputBuffer;
|
||||
|
||||
+#if !POPPLER_CHECK_VERSION(0, 73, 0)
|
||||
+static_assert(std::is_same_v<Guchar, unsigned char>, "unexpected typedef");
|
||||
+#endif
|
||||
+
|
||||
#endif // INCLUDED_SDEXT_SOURCE_PDFIMPORT_XPDFWRAPPER_PDFIOUTDEV_GPL_HXX
|
||||
|
||||
/* vim:set shiftwidth=4 softtabstop=4 expandtab: */
|
||||
diff --git a/sdext/source/pdfimport/xpdfwrapper/pnghelper.cxx b/sdext/source/pdfimport/xpdfwrapper/pnghelper.cxx
|
||||
index 4d9e3bb46b61..b5828561b7eb 100644
|
||||
--- a/sdext/source/pdfimport/xpdfwrapper/pnghelper.cxx
|
||||
+++ b/sdext/source/pdfimport/xpdfwrapper/pnghelper.cxx
|
||||
@@ -242,7 +242,7 @@ void PngHelper::createPng( OutputBuffer& o_rOutputBuf,
|
||||
appendIHDR( o_rOutputBuf, width, height, 8, 6 ); // RGBA image
|
||||
|
||||
// initialize stream
|
||||
- Guchar *p, *pm;
|
||||
+ unsigned char *p, *pm;
|
||||
GfxRGB rgb;
|
||||
GfxGray alpha;
|
||||
std::unique_ptr<ImageStream> imgStr(
|
||||
@@ -328,7 +328,7 @@ void PngHelper::createPng( OutputBuffer& o_rOutputBuf,
|
||||
appendIHDR( o_rOutputBuf, width, height, 8, 6 ); // RGBA image
|
||||
|
||||
// initialize stream
|
||||
- Guchar *p;
|
||||
+ unsigned char *p;
|
||||
GfxRGB rgb;
|
||||
std::unique_ptr<ImageStream> imgStr(
|
||||
new ImageStream(str,
|
||||
@@ -374,7 +374,7 @@ void PngHelper::createPng( OutputBuffer& o_rOutputBuf,
|
||||
{
|
||||
for( int x = 0; x < maskWidth; ++x )
|
||||
{
|
||||
- Guchar aPixel = 0;
|
||||
+ unsigned char aPixel = 0;
|
||||
imgStrMask->getPixel( &aPixel );
|
||||
int nIndex = (y*height/maskHeight) * (width*4+1) + // mapped line
|
||||
(x*width/maskWidth)*4 + 1 + 3 // mapped column
|
Loading…
Reference in a new issue