extra/mono to 3.4.0-1

This commit is contained in:
Kevin Mihelich 2014-06-26 00:14:36 +00:00
parent b748730136
commit 2417883560
3 changed files with 42 additions and 6 deletions

View file

@ -0,0 +1,4 @@
<Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
<Import Project="..\Microsoft.Portable.Core.props" />
<Import Project="..\Microsoft.Portable.Core.targets" />
</Project>

View file

@ -7,7 +7,7 @@
# and using autogen.sh to rebuild for configure.in changes.
pkgname=mono
pkgver=3.2.8
pkgver=3.4.0
pkgrel=1
pkgdesc="Free implementation of the .NET platform including runtime and compiler"
arch=(i686 x86_64)
@ -19,14 +19,21 @@ provides=('monodoc')
conflicts=('monodoc')
source=(http://download.mono-project.com/sources/mono/${pkgname}-${pkgver}.tar.bz2
mono.binfmt.d
sgen_fix.patch)
md5sums=('1075f99bd8a69890af9e30309728e684'
sgen_fix.patch
build_fix.patch
Microsoft.Portable.Common.targets)
md5sums=('698024a40ee0721c2a24c45be2e39f28'
'b9ef8a65fea497acf176cca16c1e2402'
'8a700b94bff7a913f920e95890d2fb4c')
'8a700b94bff7a913f920e95890d2fb4c'
'30a5af1a4ff50b98f9e73cc2ae554115'
'acbffadb0ac233c494b40dd5e79209a5')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -p1 < ../build_fix.patch
cp ../Microsoft.Portable.Common.targets mcs/tools/xbuild/targets/
# build mono
if [ "$CARCH" = "armv7h" -o "$CARCH" = "armv6h" ]; then
#Disabling alarm patch, arm support might be in now.
@ -36,10 +43,10 @@ build() {
sed -i 's/AM_PROG_CC_STDC/AC_PROG_CC/' configure.in
sed -i 's/AUTOMAKE_OPTIONS = cygnus//' runtime/Makefile.am
./autogen.sh --prefix=/usr --sysconfdir=/etc \
--with-fpu=VFP --bindir=/usr/bin --sbindir=/usr/bin --disable-static --disable-quiet-build --disable-system-aot
--with-fpu=VFP --bindir=/usr/bin --sbindir=/usr/bin --disable-static --disable-quiet-build --disable-system-aot --with-mcs-docs=no
else
sed -i 's/armv6=yes/armv6=no/' configure
./configure --prefix=/usr --sysconfdir=/etc --bindir=/usr/bin --sbindir=/usr/bin --with-fpu=NONE --disable-static --disable-quiet-build --disable-system-aot
./configure --prefix=/usr --sysconfdir=/etc --bindir=/usr/bin --sbindir=/usr/bin --with-fpu=NONE --disable-static --disable-quiet-build --disable-system-aot --with-mcs-docs=no
fi
make

View file

@ -0,0 +1,25 @@
From c68c72144d7b2a0516276137855d4508a3f59a17 Mon Sep 17 00:00:00 2001
From: Michael Hutchinson <m.j.hutchinson@gmail.com>
Date: Tue, 1 Apr 2014 17:21:51 -0400
Subject: [PATCH] [xbuild] Include PCL common targets in tarball
BXC18690 - Microsoft.Portable.Common.targets is missing in mono 3.4.0 tarball
---
mcs/tools/xbuild/Makefile | 1 +
1 file changed, 1 insertion(+)
diff --git a/mcs/tools/xbuild/Makefile b/mcs/tools/xbuild/Makefile
index c3a5d6a..31d5329 100644
--- a/mcs/tools/xbuild/Makefile
+++ b/mcs/tools/xbuild/Makefile
@@ -93,6 +93,7 @@ EXTRA_DISTFILES = \
frameworks/net_4.5.xml \
targets/Microsoft.Portable.CSharp_4.0.targets \
targets/Microsoft.Portable.CSharp_4.5.targets \
+ targets/Microsoft.Portable.Common.targets \
targets/Microsoft.Portable.Core.targets \
targets/Microsoft.Portable.Core.props \
targets/Microsoft.WebApplication.targets \
--
1.9.3