mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/gst-plugins-bad to 1.8.3-1
This commit is contained in:
parent
205e1fbefe
commit
28a5b7f378
2 changed files with 31 additions and 4 deletions
|
@ -7,8 +7,8 @@
|
||||||
# - disable GL and GLX on v5/6/7
|
# - disable GL and GLX on v5/6/7
|
||||||
|
|
||||||
pkgname=gst-plugins-bad
|
pkgname=gst-plugins-bad
|
||||||
pkgver=1.8.2
|
pkgver=1.8.3
|
||||||
pkgrel=4
|
pkgrel=1
|
||||||
pkgdesc="GStreamer Multimedia Framework Bad Plugins"
|
pkgdesc="GStreamer Multimedia Framework Bad Plugins"
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
license=('LGPL')
|
license=('LGPL')
|
||||||
|
@ -21,11 +21,14 @@ makedepends=(schroedinger libexif libdvdread libvdpau libmpeg2 python wildmidi l
|
||||||
qt5-declarative qt5-x11extras qt5-wayland vulkan-headers vulkan-icd-loader
|
qt5-declarative qt5-x11extras qt5-wayland vulkan-headers vulkan-icd-loader
|
||||||
zbar)
|
zbar)
|
||||||
options=(!emptydirs)
|
options=(!emptydirs)
|
||||||
source=(${url}/src/$pkgname/$pkgname-$pkgver.tar.xz)
|
source=(${url}/src/$pkgname/$pkgname-$pkgver.tar.xz
|
||||||
sha256sums=('d7995317530c8773ec088f94d9320909d41da61996b801ebacce9a56af493f97')
|
wildmidi-0.4.patch)
|
||||||
|
sha256sums=('7899fcb18e6a1af2888b19c90213af018a57d741c6e72ec56b133bc73ec8509b'
|
||||||
|
'b234c5d1a8b33342d9f807a46c26623e21f3d1b33a9b2903a41fadd53e0cac47')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd $pkgname-$pkgver
|
cd $pkgname-$pkgver
|
||||||
|
patch -Np1 -i ../wildmidi-0.4.patch
|
||||||
autoreconf -vi
|
autoreconf -vi
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
24
extra/gst-plugins-bad/wildmidi-0.4.patch
Normal file
24
extra/gst-plugins-bad/wildmidi-0.4.patch
Normal file
|
@ -0,0 +1,24 @@
|
||||||
|
From 04199db2aeea966c2c879b1764427c87433570f1 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Sebastian=20Dr=C3=B6ge?= <sebastian@centricular.com>
|
||||||
|
Date: Tue, 16 Aug 2016 10:37:28 +0300
|
||||||
|
Subject: wildmidi: Fix compilation with wildmidi 0.4
|
||||||
|
|
||||||
|
Old versions used char* for the data, new versions use int8_t*. They're often
|
||||||
|
not the same and differ in signedness.
|
||||||
|
|
||||||
|
diff --git a/ext/timidity/gstwildmidi.c b/ext/timidity/gstwildmidi.c
|
||||||
|
index 3e82ca2..f52ea9d 100644
|
||||||
|
--- a/ext/timidity/gstwildmidi.c
|
||||||
|
+++ b/ext/timidity/gstwildmidi.c
|
||||||
|
@@ -672,7 +672,7 @@ gst_wildmidi_get_buffer (GstWildmidi * wildmidi)
|
||||||
|
gst_buffer_map (buffer, &info, GST_MAP_READWRITE);
|
||||||
|
|
||||||
|
GST_OBJECT_LOCK (wildmidi);
|
||||||
|
- size = WildMidi_GetOutput (wildmidi->song, (char *) info.data,
|
||||||
|
+ size = WildMidi_GetOutput (wildmidi->song, (gpointer) info.data,
|
||||||
|
(unsigned long int) info.size);
|
||||||
|
GST_OBJECT_UNLOCK (wildmidi);
|
||||||
|
|
||||||
|
--
|
||||||
|
cgit v0.10.2
|
||||||
|
|
Loading…
Reference in a new issue