Rolled together dockstar and withlinux kernels into one big, awesome kernel with hundreds of new features

This commit is contained in:
Mike Staszel 2010-11-30 21:58:20 -06:00
parent 24d2bad854
commit 2ae9159945
8 changed files with 3352 additions and 70 deletions

View file

@ -1,22 +0,0 @@
--- a/arch/arm/mach-kirkwood/Kconfig
+++ b/arch/arm/mach-kirkwood/Kconfig
@@ -27,10 +27,10 @@ config MACH_MV88F6281GTW_GE
Marvell 88F6281 GTW GE Board.
config MACH_SHEEVAPLUG
- bool "Marvell SheevaPlug Reference Board"
+ bool "Seagate DockStar Board"
help
Say 'Y' here if you want your kernel to support the
- Marvell SheevaPlug Reference Board.
+ Seagate DockStar Board.
config MACH_TS219
bool "QNAP TS-110, TS-119, TS-210, TS-219 and TS-219P Turbo NAS"
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c
@@ -143,1 +143,1 @@
-MACHINE_START(SHEEVAPLUG, "Marvell SheevaPlug Reference Board")
+MACHINE_START(SHEEVAPLUG, "Seagate DockStar Board")
--

View file

@ -1,48 +0,0 @@
# Maintainer: Mike Staszel <mikestaszel@gmail.com>
# This PKGBUILD builds a kernel using cbxbiker's With-Linux configuration.
pkgname=kernel26-withlinux
pkgver=2.6.36
pkgrel=2
pkgdesc="The Linux Kernel and modules from WithLinux, natively compiled"
arch=('arm')
license=('GPL2')
url="http://www.kernel.org"
depends=('coreutils' 'module-init-tools')
makedepends=('uboot-mkimage')
conflicts=('kernel26')
provides=('kernel26')
install=kernel26-withlinux.install
source=(http://www.kernel.org/pub/linux/kernel/v2.6/linux-$pkgver.tar.bz2
http://sheeva.with-linux.com/sheeva/$pkgver/sheeva-$pkgver.config
scsi.h)
md5sums=('61f3739a73afb6914cb007f37fb09b62'
'2018fee579704d17905476cfba79bdaf'
'4e6a77d9f8ebc242eb3b7694cf86643b')
LDFLAGS=""
build() {
cd $srcdir/linux-$pkgver
# Move the configuration
mv $srcdir/sheeva-$pkgver.config .config
# To enable USB over IP
make menuconfig
# Make!
make modules uImage || return 1
# Pack up the created uImage
mkdir -p $pkgdir/boot
cp $srcdir/linux-$pkgver/arch/arm/boot/uImage $pkgdir/boot/uImage
# Make and package kernel modules
mkdir -p $pkgdir/{lib/modules,boot}
make INSTALL_MOD_PATH=${pkgdir} modules_install || return 1
# Hack to put in scsi.h
mkdir -p $pkgdir/usr/include/scsi
cp $srcdir/scsi.h $pkgdir/usr/include/scsi/
}

File diff suppressed because it is too large Load diff

60
core/kernel26/PKGBUILD Normal file
View file

@ -0,0 +1,60 @@
# Maintainer: Mike Staszel <mikestaszel@gmail.com>
# This PKGBUILD builds a kernel for most plugs.
pkgname=kernel26
pkgver=2.6.36.1
pkgrel=1
pkgdesc="The Linux Kernel and modules"
arch=('arm')
license=('GPL2')
url="http://www.kernel.org"
depends=('coreutils' 'module-init-tools')
makedepends=('uboot-mkimage')
conflicts=('kernel26')
replaces=('kernel26-withlinux' 'kernel26-dockstar')
provides=('kernel26')
install=kernel26.install
source=(http://www.kernel.org/pub/linux/kernel/v2.6/linux-$pkgver.tar.bz2
$pkgver.config
0001-MTD-partitons-used-by-the-Seagate-FreeAgent-DockStar.patch
0002-LED-definitions-for-the-Seagate-FreeAgent-DockStar.patch
scsi.h)
md5sums=('0f1398ad1fcfc14f2420010bc8a03ca9'
'8a6da52da0464eb435de9c718fa526b8'
'0ed85186b0b5446c4afbbc45639a7466'
'e81eae381cc2c282d169c879cc4da54b'
'4e6a77d9f8ebc242eb3b7694cf86643b')
LDFLAGS=""
build() {
cd $srcdir/
cp 000* $pkgver.config linux-$pkgver/
cd linux-$pkgver
mv $pkgver.config .config
# Apply Aholler's DockStar hardware patches
patch -p1 -i 0001-MTD-partitons-used-by-the-Seagate-FreeAgent-DockStar.patch
patch -p1 -i 0002-LED-definitions-for-the-Seagate-FreeAgent-DockStar.patch
# Just in case you want to change things
# make menuconfig
# Make!
make modules uImage || return 1
# Pack up the created uImage
mkdir -p $pkgdir/boot
cp $srcdir/linux-$pkgver/arch/arm/boot/uImage $pkgdir/boot/uImage
# Make and package kernel modules
mkdir -p $pkgdir/{lib/modules,boot}
make INSTALL_MOD_PATH=${pkgdir} modules_install || return 1
# Remove the symlink to the build machine's build directory
rm $pkgdir/lib/modules/$pkgver/build
# Hack to put in scsi.h
mkdir -p $pkgdir/usr/include/scsi
cp $srcdir/scsi.h $pkgdir/usr/include/scsi/
}

View file

@ -3,6 +3,7 @@ echo -e "\033[1mNotice\033[0m"
echo "If you have a SheevaPlug, you will have to copy"
echo "/boot/uImage to the proper location, e.g. mmcblk0p1."
echo ""
echo "This package is for all plugs, including the DockStar."
}
post_upgrade() {