extra/firefox to 70.0.1-3

This commit is contained in:
Kevin Mihelich 2019-11-22 13:40:08 +00:00
parent 99db6fdd59
commit 2d6b25320d
2 changed files with 1 additions and 39 deletions

View file

@ -1,33 +0,0 @@
From 9e8f88c9ae80a2fc984f86f322cd6f2548722789 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Thu, 21 Nov 2019 21:32:55 +0100
Subject: [PATCH] Bug 1593167, ensure that loadable certs are loaded when
TransportSecurityInfo::Read is called
Backported to Firefox 70.
https://phabricator.services.mozilla.com/D54135
---
security/manager/ssl/TransportSecurityInfo.cpp | 6 ++++++
1 file changed, 6 insertions(+)
diff --git a/security/manager/ssl/TransportSecurityInfo.cpp b/security/manager/ssl/TransportSecurityInfo.cpp
index dd3e12a19d41..224ac86ecf1c 100644
--- a/security/manager/ssl/TransportSecurityInfo.cpp
+++ b/security/manager/ssl/TransportSecurityInfo.cpp
@@ -444,6 +444,12 @@ TransportSecurityInfo::Read(nsIObjectInputStream* aStream) {
return rv;
}
+ // The logic below needs access to loadable certs.
+ rv = BlockUntilLoadableRootsLoaded();
+ if (NS_FAILED(rv)) {
+ return rv;
+ }
+
// moved from nsISSLStatus
if (!serVersion.EqualsASCII("1")) {
// nsISSLStatus may be present
--
2.24.0

View file

@ -12,7 +12,7 @@ noautobuild=1
pkgname=firefox
pkgver=70.0.1
pkgrel=2
pkgrel=3
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
license=(MPL GPL LGPL)
@ -34,7 +34,6 @@ source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-
build-arm-libopus.patch
0001-Update-bindgen.patch
0002-Bug-1212502-Switch-mozinfo-to-using-the-distro-packa.patch
0001-Bug-1593167-ensure-that-loadable-certs-are-loaded-wh.patch
0001-Use-remoting-name-for-GDK-application-names.patch
$pkgname.desktop)
sha256sums=('f2e9bb26af7682b31e82fdfc3a4b3e04fd1caa8b004469ea608185d33e35691b'
@ -42,7 +41,6 @@ sha256sums=('f2e9bb26af7682b31e82fdfc3a4b3e04fd1caa8b004469ea608185d33e35691b'
'2dc9d1aa5eb7798c89f46478f254ae61e4122b4d1956d6044426288627d8a014'
'832d895c90d346fe4acf25b8b8ba9a62bea595fe5fcdeaf545c8e952393993fc'
'58890388e02af41055e1ec9797b7c094dee499a5219dc9c532c6cfccf2cce972'
'c0e8176d7382649b7423d809fd586b01b50e95df816ef34237683c2598802c2f'
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
'ab07ab26617ff76fce68e07c66b8aa9b96c2d3e5b5517e51a3c3eac2edd88894'
@ -73,9 +71,6 @@ prepare() {
patch -Np1 -i ../0001-Update-bindgen.patch
patch -Np1 -i ../0002-Bug-1212502-Switch-mozinfo-to-using-the-distro-packa.patch
# https://bugzilla.mozilla.org/show_bug.cgi?id=1593167
patch -Np1 -i ../0001-Bug-1593167-ensure-that-loadable-certs-are-loaded-wh.patch
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch