mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
added community/fbreader, fixes #463
This commit is contained in:
parent
2c9c0eddf0
commit
31a1cf61aa
2 changed files with 56 additions and 0 deletions
35
community/fbreader/PKGBUILD
Normal file
35
community/fbreader/PKGBUILD
Normal file
|
@ -0,0 +1,35 @@
|
|||
# $Id: PKGBUILD 85342 2013-03-01 10:29:55Z andrea $
|
||||
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
|
||||
# Contributor: William Rea <sillywilly@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to cast qReal's to double's to work with ARM
|
||||
|
||||
pkgname=fbreader
|
||||
pkgver=0.99.4
|
||||
pkgrel=2
|
||||
pkgdesc="An e-book reader for Linux"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.fbreader.org/"
|
||||
license=('GPL')
|
||||
depends=('fribidi' 'bzip2' 'curl' 'qt4' 'liblinebreak' 'sqlite')
|
||||
makedepends=('ccache')
|
||||
source=(http://www.fbreader.org/files/desktop/fbreader-sources-$pkgver.tgz
|
||||
arm.patch)
|
||||
md5sums=('ed13a9c3aeb68aaa98a1dd6f7947a31d'
|
||||
'9e6f7c9437c193be6c7fb18978bdf876')
|
||||
|
||||
build() {
|
||||
export TARGET_ARCH=desktop
|
||||
export UI_TYPE=qt4
|
||||
export TARGET_STATUS=release
|
||||
cd $srcdir/fbreader-$pkgver
|
||||
patch -p1 -i ../arm.patch
|
||||
sed -i 's|-lunibreak|-llinebreak|g' makefiles/config.mk zlibrary/text/Makefile
|
||||
make ZLSHARED=no MOC=/usr/bin/moc-qt4
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $srcdir/fbreader-$pkgver
|
||||
make ZLSHARED=no DESTDIR=$pkgdir install
|
||||
}
|
21
community/fbreader/arm.patch
Normal file
21
community/fbreader/arm.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
diff -urN a/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp b/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp
|
||||
--- a/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp 2012-11-30 05:41:25.000000000 -0700
|
||||
+++ b/zlibrary/ui/src/qt4/tree/QtWaitingSpinner.cpp 2013-04-21 10:17:23.402543440 -0600
|
||||
@@ -86,7 +86,7 @@
|
||||
}
|
||||
|
||||
void QtWaitingSpinner::setRoundness(qreal roundness) {
|
||||
- myRoundness = std::max(0.0, std::min(100.0, roundness));
|
||||
+ myRoundness = std::max(0.0, std::min(100.0, (double)roundness));
|
||||
}
|
||||
|
||||
void QtWaitingSpinner::setColor(QColor color) {
|
||||
@@ -148,7 +148,7 @@
|
||||
qreal alphaDiff = color.alphaF() - (qreal)minAlphaF;
|
||||
qreal gradation = alphaDiff / (qreal)(distanceThreshold + 1);
|
||||
qreal resultAlpha = color.alphaF() - gradation * distance;
|
||||
- resultAlpha = std::min(1.0, std::max(0.0, resultAlpha)); //if alpha is out of bound, force it to bounds
|
||||
+ resultAlpha = std::min(1.0, std::max(0.0, (double)resultAlpha)); //if alpha is out of bound, force it to bounds
|
||||
color.setAlphaF(resultAlpha);
|
||||
return color;
|
||||
}
|
Loading…
Reference in a new issue