mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/qt5-base to 5.11.0-1
This commit is contained in:
parent
963e5eec43
commit
348220fe16
4 changed files with 8 additions and 158 deletions
|
@ -9,15 +9,15 @@
|
|||
|
||||
pkgbase=qt5-base
|
||||
pkgname=(qt5-base qt5-xcb-private-headers)
|
||||
_qtver=5.10.1
|
||||
_qtver=5.11.0
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=8
|
||||
pkgrel=1
|
||||
arch=('x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('GPL3' 'LGPL3' 'FDL' 'custom')
|
||||
pkgdesc='A cross-platform application and UI framework'
|
||||
depends=('libjpeg-turbo' 'xcb-util-keysyms' 'xcb-util-renderutil' 'libgl' 'fontconfig' 'xdg-utils'
|
||||
'xcb-util-wm' 'libxrender' 'libxi' 'sqlite' 'xcb-util-image' 'icu' 'pcre2' 'shared-mime-info'
|
||||
depends=('libjpeg-turbo' 'xcb-util-keysyms' 'xcb-util-renderutil' 'libgl' 'fontconfig' 'xdg-utils' 'shared-mime-info'
|
||||
'xcb-util-wm' 'libxrender' 'libxi' 'sqlite' 'xcb-util-image' 'icu' 'pcre2'
|
||||
'tslib' 'libinput' 'libsm' 'libxkbcommon-x11' 'libproxy' 'libcups' 'double-conversion')
|
||||
makedepends=('libfbclient' 'libmariadbclient' 'sqlite' 'unixodbc' 'postgresql-libs' 'alsa-lib' 'gst-plugins-base-libs'
|
||||
'gtk3' 'libpulse' 'cups' 'freetds' 'vulkan-headers')
|
||||
|
@ -32,19 +32,9 @@ conflicts=('qtchooser')
|
|||
groups=('qt' 'qt5')
|
||||
_pkgfqn="${pkgbase/5-/}-everywhere-src-${_qtver}"
|
||||
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
|
||||
revert-Set-sharedPainter-correctly-for-QGraphicsEffect.patch
|
||||
qtbug-65478.patch
|
||||
qheaderview-restore.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=4a04eea4"
|
||||
qtbug-66444.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=9395f35c"
|
||||
qtbug-66420.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=fa091640"
|
||||
qtbug-66816.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=e4e87a2e")
|
||||
sha256sums=('d8660e189caa5da5142d5894d328b61a4d3ee9750b76d61ad74e4eee8765a969'
|
||||
'7161ea5747500dc9666f8d185f4b8e538799fc0aef574e577277747100ac4763'
|
||||
'b2e8cb06c60be7de31a984c4cfc9ab85c9e2d08c1a3d93136f193735b43600c6'
|
||||
'3a1016cbf8c3c4676e6fc406756ffa5a151ffe09153dfc0fa7ed3c16945b0ae5'
|
||||
'88766a7b73a03e1219800c8fdc56afbf23b15d16cc61c4d77547b1fd2404ea6e'
|
||||
'9e21893545f950132c9face1d502d32e746b2838d4e8c9075dcf3fa43981fcb2'
|
||||
'2e1ee522eb3503c1359286269eec09d02ca16381769035c3d3bc663b129580db')
|
||||
qt-private-includes.patch::"http://code.qt.io/cgit/qt/qtbase.git/patch/?id=67aa365d")
|
||||
sha256sums=('ed6e46db84f7d34923ab4eae165c63e05ab3cfa9d19a73d3f57b4e7bfd41de66'
|
||||
'bf6e52cc613599ff3dc756113ffb61aa1896a84abefbe69f42bdb846202d1f71')
|
||||
|
||||
prepare() {
|
||||
cd ${_pkgfqn}
|
||||
|
@ -61,21 +51,7 @@ prepare() {
|
|||
's|#![ ]*/usr/bin/python$|&2|;s|#![ ]*/usr/bin/env python$|&2|' {} +
|
||||
|
||||
# Fix missing private includes https://bugreports.qt.io/browse/QTBUG-37417
|
||||
sed -e '/CMAKE_NO_PRIVATE_INCLUDES\ \=\ true/d' -i mkspecs/features/create_cmake.prf
|
||||
|
||||
# Revert upstream commit which breaks some Deepin components (FS#57531)
|
||||
# https://bugreports.qt.io/browse/QTBUG-66226
|
||||
patch -Np1 -i ../revert-Set-sharedPainter-correctly-for-QGraphicsEffect.patch
|
||||
# Fix kexi crash at startup http://bugreports.qt.io/browse/QTBUG-65478
|
||||
patch -p1 -i ../qtbug-65478.patch
|
||||
# Fix restoring column status in kmail and ksysguard
|
||||
patch -p1 -i ../qheaderview-restore.patch
|
||||
# Fix QHeaderView regression https://bugreports.qt.io/browse/QTBUG-66444
|
||||
patch -p1 -i ../qtbug-66444.patch
|
||||
# Fix white screen with Mesa 18 https://bugreports.qt.io/browse/QTBUG-66420
|
||||
patch -p1 -i ../qtbug-66420.patch
|
||||
# Fix crashes in QSqlite http://bugreports.qt.io/browse/QTBUG-66816
|
||||
patch -p1 -i ../qtbug-66816.patch
|
||||
patch -p1 -i ../qt-private-includes.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
From e8425f9e52c9df0ce0fbf122adff3ef6930f9961 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Thorbj=C3=B8rn=20Lund=20Martsum?= <tmartsum@gmail.com>
|
||||
Date: Wed, 28 Feb 2018 09:23:54 +0100
|
||||
Subject: QHeaderView: Fix crash in layout about to change
|
||||
|
||||
Before there was a risk looking up e.g index -1 if there
|
||||
were no visible sections in layoutAboutToChange.
|
||||
|
||||
Change-Id: Ic911e4292e8e8c4892fef1c0f34cf7dccaad2bac
|
||||
Task-number: QTBUG-65478
|
||||
Reviewed-by: David Faure <david.faure@kdab.com>
|
||||
---
|
||||
diff --git a/src/widgets/itemviews/qheaderview.cpp b/src/widgets/itemviews/qheaderview.cpp
|
||||
index 26d7c5472a..708b9b44ca 100644
|
||||
--- a/src/widgets/itemviews/qheaderview.cpp
|
||||
+++ b/src/widgets/itemviews/qheaderview.cpp
|
||||
@@ -2163,9 +2163,11 @@ void QHeaderViewPrivate::_q_sectionsAboutToBeChanged()
|
||||
layoutChangePersistentSections.clear();
|
||||
layoutChangePersistentSections.reserve(std::min(10, sectionItems.count()));
|
||||
// after layoutChanged another section can be last stretched section
|
||||
- if (stretchLastSection) {
|
||||
+ if (stretchLastSection && lastSectionLogicalIdx >= 0 && lastSectionLogicalIdx < sectionItems.count()) {
|
||||
const int visual = visualIndex(lastSectionLogicalIdx);
|
||||
- sectionItems[visual].size = lastSectionSize;
|
||||
+ if (visual >= 0 && visual < sectionItems.size()) {
|
||||
+ sectionItems[visual].size = lastSectionSize;
|
||||
+ }
|
||||
}
|
||||
for (int i = 0; i < sectionItems.size(); ++i) {
|
||||
auto s = sectionItems.at(i);
|
||||
|
|
@ -1,24 +0,0 @@
|
|||
### Rebuild only for minor version updates
|
||||
calibre
|
||||
gcin
|
||||
googlemaps
|
||||
kwin
|
||||
lxqt-qtplugin
|
||||
plasma-framework
|
||||
plasma-integration
|
||||
qqc2-desktop-style
|
||||
qt5ct
|
||||
### Rebuild for minor and patch version updates
|
||||
akonadi
|
||||
deepin-dock
|
||||
deepin-file-manager
|
||||
deepin-qt5integration
|
||||
deepin-qt5dxcb-plugin
|
||||
dtkwidget
|
||||
dtkwm
|
||||
fcitx-qt5
|
||||
libqtxdg
|
||||
pyqt5
|
||||
qt5-styleplugins
|
||||
qt5-webkit
|
||||
skrooge
|
|
@ -1,71 +0,0 @@
|
|||
From f4bc1f620727366b6a977b106cc68fade95ef426 Mon Sep 17 00:00:00 2001
|
||||
From: Evangelos Foutras <evangelos@foutrelis.com>
|
||||
Date: Wed, 21 Feb 2018 04:20:20 +0200
|
||||
Subject: [PATCH] Revert "Set sharedPainter correctly for QGraphicsEffect"
|
||||
|
||||
This reverts commit 7257862fb2edfab0219d6cd45c83677049404f7d.
|
||||
---
|
||||
src/widgets/kernel/qwidget.cpp | 4 ++--
|
||||
.../effects/qgraphicseffect/tst_qgraphicseffect.cpp | 21 ---------------------
|
||||
2 files changed, 2 insertions(+), 23 deletions(-)
|
||||
|
||||
diff --git a/src/widgets/kernel/qwidget.cpp b/src/widgets/kernel/qwidget.cpp
|
||||
index a973bee2cd..256c77e5a0 100644
|
||||
--- a/src/widgets/kernel/qwidget.cpp
|
||||
+++ b/src/widgets/kernel/qwidget.cpp
|
||||
@@ -5482,11 +5482,11 @@ void QWidgetPrivate::drawWidget(QPaintDevice *pdev, const QRegion &rgn, const QP
|
||||
setSystemClip(pdev->paintEngine(), pdev->devicePixelRatioF(), rgn.translated(offset));
|
||||
QPainter p(pdev);
|
||||
p.translate(offset);
|
||||
- context.painter = context.sharedPainter = &p;
|
||||
+ context.painter = &p;
|
||||
graphicsEffect->draw(&p);
|
||||
setSystemClip(pdev->paintEngine(), 1, QRegion());
|
||||
} else {
|
||||
- context.painter = context.sharedPainter = sharedPainter;
|
||||
+ context.painter = sharedPainter;
|
||||
if (sharedPainter->worldTransform() != sourced->lastEffectTransform) {
|
||||
sourced->invalidateCache();
|
||||
sourced->lastEffectTransform = sharedPainter->worldTransform();
|
||||
diff --git a/tests/auto/widgets/effects/qgraphicseffect/tst_qgraphicseffect.cpp b/tests/auto/widgets/effects/qgraphicseffect/tst_qgraphicseffect.cpp
|
||||
index dfe5baba71..a1cb729849 100644
|
||||
--- a/tests/auto/widgets/effects/qgraphicseffect/tst_qgraphicseffect.cpp
|
||||
+++ b/tests/auto/widgets/effects/qgraphicseffect/tst_qgraphicseffect.cpp
|
||||
@@ -52,7 +52,6 @@ private slots:
|
||||
void boundingRect2();
|
||||
void draw();
|
||||
void opacity();
|
||||
- void nestedOpaqueOpacity();
|
||||
void grayscale();
|
||||
void colorize();
|
||||
void drawPixmapItem();
|
||||
@@ -408,26 +407,6 @@ void tst_QGraphicsEffect::opacity()
|
||||
QCOMPARE(effect->m_opacity, qreal(0.5));
|
||||
}
|
||||
|
||||
-void tst_QGraphicsEffect::nestedOpaqueOpacity()
|
||||
-{
|
||||
- // QTBUG-60231: Nesting widgets with a QGraphicsEffect on a toplevel with
|
||||
- // QGraphicsOpacityEffect caused crashes due to constructing several
|
||||
- // QPainter instances on a device in the fast path for
|
||||
- // QGraphicsOpacityEffect::opacity=1
|
||||
- QWidget topLevel;
|
||||
- topLevel.setWindowTitle(QTest::currentTestFunction());
|
||||
- topLevel.resize(320, 200);
|
||||
- QGraphicsOpacityEffect *opacityEffect = new QGraphicsOpacityEffect;
|
||||
- opacityEffect->setOpacity(1);
|
||||
- topLevel.setGraphicsEffect(opacityEffect);
|
||||
- QWidget *child = new QWidget(&topLevel);
|
||||
- child->resize(topLevel.size() / 2);
|
||||
- QGraphicsDropShadowEffect *childEffect = new QGraphicsDropShadowEffect;
|
||||
- child->setGraphicsEffect(childEffect);
|
||||
- topLevel.show();
|
||||
- QVERIFY(QTest::qWaitForWindowExposed(&topLevel));
|
||||
-}
|
||||
-
|
||||
void tst_QGraphicsEffect::grayscale()
|
||||
{
|
||||
if (qApp->desktop()->depth() < 24)
|
||||
--
|
||||
2.16.2
|
||||
|
Loading…
Reference in a new issue