mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
community/libuhd to 3.14.0.0-1
This commit is contained in:
parent
bfb9f3c40d
commit
36081a8dce
4 changed files with 10 additions and 92 deletions
|
@ -1,39 +0,0 @@
|
||||||
From d48353b54007a39d8ef9cb53c3d18adf8be9b62c Mon Sep 17 00:00:00 2001
|
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
Date: Sat, 14 May 2016 11:08:46 -0600
|
|
||||||
Subject: [PATCH] remove ineffectual neon check
|
|
||||||
|
|
||||||
---
|
|
||||||
host/lib/convert/CMakeLists.txt | 16 ----------------
|
|
||||||
1 file changed, 16 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/host/lib/convert/CMakeLists.txt b/host/lib/convert/CMakeLists.txt
|
|
||||||
index 10376ba..4d793c4 100644
|
|
||||||
--- a/host/lib/convert/CMakeLists.txt
|
|
||||||
+++ b/host/lib/convert/CMakeLists.txt
|
|
||||||
@@ -54,22 +54,6 @@ IF(HAVE_EMMINTRIN_H)
|
|
||||||
ENDIF(HAVE_EMMINTRIN_H)
|
|
||||||
|
|
||||||
########################################################################
|
|
||||||
-# Check for NEON SIMD headers
|
|
||||||
-########################################################################
|
|
||||||
-IF(CMAKE_COMPILER_IS_GNUCXX)
|
|
||||||
- CHECK_INCLUDE_FILE_CXX(arm_neon.h HAVE_ARM_NEON_H)
|
|
||||||
-ENDIF(CMAKE_COMPILER_IS_GNUCXX)
|
|
||||||
-
|
|
||||||
-IF(HAVE_ARM_NEON_H AND (${CMAKE_SIZEOF_VOID_P} EQUAL 4))
|
|
||||||
- ENABLE_LANGUAGE(ASM)
|
|
||||||
-
|
|
||||||
- LIBUHD_APPEND_SOURCES(
|
|
||||||
- ${CMAKE_CURRENT_SOURCE_DIR}/convert_with_neon.cpp
|
|
||||||
- ${CMAKE_CURRENT_SOURCE_DIR}/convert_neon.S
|
|
||||||
- )
|
|
||||||
-ENDIF()
|
|
||||||
-
|
|
||||||
-########################################################################
|
|
||||||
# Convert types generation
|
|
||||||
########################################################################
|
|
||||||
INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
|
|
||||||
--
|
|
||||||
2.8.2
|
|
||||||
|
|
|
@ -2,11 +2,11 @@
|
||||||
# Contributor: Dominik Heidler <dheidler@gmail.com>
|
# Contributor: Dominik Heidler <dheidler@gmail.com>
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
# - patch out ineffectual neon check
|
# - set -DNEON_SIMD_ENABLE=OFF
|
||||||
|
|
||||||
pkgname=libuhd
|
pkgname=libuhd
|
||||||
pkgver=3.13.0.1
|
pkgver=3.14.0.0
|
||||||
pkgrel=3
|
pkgrel=1
|
||||||
pkgdesc="Universal Software Radio Peripheral (USRP) userspace driver"
|
pkgdesc="Universal Software Radio Peripheral (USRP) userspace driver"
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
url="http://www.ettus.com/kb/category/software-documentation/uhd-manual"
|
url="http://www.ettus.com/kb/category/software-documentation/uhd-manual"
|
||||||
|
@ -14,27 +14,19 @@ license=('GPL')
|
||||||
depends=('boost-libs' 'orc' 'libusb')
|
depends=('boost-libs' 'orc' 'libusb')
|
||||||
optdepends=('python2: usrp utils')
|
optdepends=('python2: usrp utils')
|
||||||
makedepends=('cmake' 'boost' 'python2-mako')
|
makedepends=('cmake' 'boost' 'python2-mako')
|
||||||
|
# gpsd? dpdk?
|
||||||
|
|
||||||
source=("libuhd-$pkgver.tar.gz::https://github.com/EttusResearch/uhd/archive/v$pkgver.tar.gz"
|
source=("libuhd-$pkgver.tar.gz::https://github.com/EttusResearch/uhd/archive/v$pkgver.tar.gz")
|
||||||
'boost-1.67.patch'
|
md5sums=('bc195e12bbdf95eaf88ce20be453020d')
|
||||||
'boost-1.69.patch'
|
|
||||||
'0001-remove-ineffectual-neon-check.patch')
|
|
||||||
md5sums=('e7c38546d9dadac41657ee5e53c3f342'
|
|
||||||
'45fcc6feb0ea9b4ae09e4ba7b010864f'
|
|
||||||
'ae53a647b13a9187a3c8b965bfbde2c1'
|
|
||||||
'2cb16216ee735ab1160e572d523155ea')
|
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "$srcdir/uhd-$pkgver"
|
cd "$srcdir/uhd-$pkgver"
|
||||||
patch -Np1 -i ../boost-1.67.patch
|
# fix for py2
|
||||||
patch -Np1 -i ../boost-1.69.patch
|
find -name "*.py" -or -name '*.py.in' | xargs sed -i "s|#!/usr/bin/env python$|#!/usr/bin/env python2|"
|
||||||
patch -Np1 -i ../0001-remove-ineffectual-neon-check.patch
|
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "$srcdir/uhd-$pkgver/host"
|
cd "$srcdir/uhd-$pkgver/host"
|
||||||
# fix for py2
|
|
||||||
find -name "*.py" -or -name '*.py.in' | xargs sed -i "s|#!/usr/bin/env python$|#!/usr/bin/env python2|"
|
|
||||||
|
|
||||||
mkdir -p build
|
mkdir -p build
|
||||||
cd build
|
cd build
|
||||||
|
@ -44,7 +36,8 @@ build() {
|
||||||
-DENABLE_UTILS=ON \
|
-DENABLE_UTILS=ON \
|
||||||
-DENABLE_TESTS=OFF \
|
-DENABLE_TESTS=OFF \
|
||||||
-DENABLE_E100=ON \
|
-DENABLE_E100=ON \
|
||||||
-DENABLE_E300=ON
|
-DENABLE_E300=ON \
|
||||||
|
-DNEON_SIMD_ENABLE=OFF
|
||||||
make
|
make
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
|
@ -1,12 +0,0 @@
|
||||||
diff -upr uhd-3.11.1.0.orig/host/lib/usrp/e300/e300_fifo_config.cpp uhd-3.11.1.0/host/lib/usrp/e300/e300_fifo_config.cpp
|
|
||||||
--- uhd-3.11.1.0.orig/host/lib/usrp/e300/e300_fifo_config.cpp 2018-05-16 22:25:48.000000000 +0300
|
|
||||||
+++ uhd-3.11.1.0/host/lib/usrp/e300/e300_fifo_config.cpp 2018-06-03 00:16:53.119018076 +0300
|
|
||||||
@@ -107,7 +107,7 @@ struct e300_fifo_poll_waiter
|
|
||||||
boost::mutex::scoped_lock l(_mutex);
|
|
||||||
if (_poll_claimed)
|
|
||||||
{
|
|
||||||
- _cond.timed_wait(l, boost::posix_time::microseconds(timeout*1000000));
|
|
||||||
+ _cond.timed_wait(l, boost::posix_time::microseconds(long(timeout*1000000)));
|
|
||||||
}
|
|
||||||
else
|
|
||||||
{
|
|
|
@ -1,24 +0,0 @@
|
||||||
From 5c012cad7858cadcaa85ec295080f3c8b21fdee0 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Martin Braun <martin.braun@ettus.com>
|
|
||||||
Date: Wed, 9 Jan 2019 09:17:07 -0800
|
|
||||||
Subject: [PATCH] lib: experts: Add potentially missing but sometimes inferred
|
|
||||||
include
|
|
||||||
|
|
||||||
This adds an include for boost/core/noncopyable.hpp. Without it, builds
|
|
||||||
would potentially fail on Boost 1.69++.
|
|
||||||
---
|
|
||||||
host/lib/include/uhdlib/experts/expert_nodes.hpp | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/host/lib/include/uhdlib/experts/expert_nodes.hpp b/host/lib/include/uhdlib/experts/expert_nodes.hpp
|
|
||||||
index 697ca19c3..8fa183835 100644
|
|
||||||
--- a/host/lib/include/uhdlib/experts/expert_nodes.hpp
|
|
||||||
+++ b/host/lib/include/uhdlib/experts/expert_nodes.hpp
|
|
||||||
@@ -12,6 +12,7 @@
|
|
||||||
#include <uhd/exception.hpp>
|
|
||||||
#include <uhd/utils/dirty_tracked.hpp>
|
|
||||||
#include <uhd/types/time_spec.hpp>
|
|
||||||
+#include <boost/core/noncopyable.hpp>
|
|
||||||
#include <boost/function.hpp>
|
|
||||||
#include <boost/thread/recursive_mutex.hpp>
|
|
||||||
#include <boost/thread.hpp>
|
|
Loading…
Reference in a new issue